• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 03:34:03 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Re: Bridge 1.1.5

Started by EdbO, July 06, 2006, 02:39:52 PM

Previous topic - Next topic

EdbO

July 06, 2006, 02:39:52 PM Last Edit: July 07, 2006, 05:33:15 PM by Orstio
I've installed the bridge and almost everything is working good, But I can't post any topic or reply when SMF is wrapped into Joomla. Unwrapped from Joomla I can post topics and reply on topics.

I got the error :
You already submitted this post! You might have accidently double clicked, or tried to refresh.
But I only clicked once. Is this a cookie problem?

Installed:
Joomla 1.0.10
SMF 1.1 RC2
Bridge 1.1.5

(Searching the forum gaves me everytime an error that the server was overloaded :-(  )


Orstio

QuoteI've installed the bridge and almost everything is working good, But I can't post any topic or reply when SMF is wrapped into Joomla. Unwrapped from Joomla I can post topics and reply on topics.

I got the error :

Code:
You already submitted this post! You might have accidently double clicked, or tried to refresh. But I only clicked once. Is this a cookie problem?

Installed:
Joomla 1.0.10
SMF 1.1 RC2
Bridge 1.1.5

(Searching the forum gaves me everytime an error that the server was overloaded :-(  )

First, go to your SMF admin panel, Posts and Topics, and make absolutely sure there is a value in the field marked:

Time required between posts from the same IP (?):

Put in a reasonably high value (I have 45 seconds for mine).  This is just to make sure that spammers can't post any more often than that.

Now, find this in SMF's Sources/Post.php:

// Prevent double submission of this form.
checkSubmitOnce('check');


and change it to this:

// Prevent double submission of this form.
//checkSubmitOnce('check');


Please note that this is not a change recommended for everyone!  This is specific to this particular user's problem, and should not be used in any other circumstances!

EdbO

Thanks!  :D This is working for me. I also had to add the last hack in Post.php.

Directy

Hi, i had the same problem in my 2 sites:

joomla 1.0.10 fresh install
SMF 1.1 RC2
Bridge 1.1.5

now is ok with this fix but why it happens?

Orstio, you say 'this is not a change recommended for everyone', what problem we can have with this fix?

thanks in advance...

Advertisement: