Advertisement:

Author Topic: Midnight Ocean  (Read 25981 times)

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Midnight Ocean
« on: April 08, 2006, 11:56:04 AM »
Link to the theme


A beautiful blue theme that uses PNG images and transparancy in Firefox and Opera, but switches to using gif images in IE.

I have now also converted this theme to work with 1.0.7 (and probably 1.0.6).  The 1.0.7 version also has some improvements and optimizations that I will be adding to the original version of this theme at a later date.  Demo of the 1.0.7 version is available here.

Background used with permission from xG Hopx (original background is a wallpaper called Lapse).
« Last Edit: June 17, 2006, 06:45:54 AM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline Bitwiz44

  • Jr. Member
  • **
  • Posts: 123
  • Gender: Male
Re: Midngight Ocean
« Reply #1 on: April 13, 2006, 08:08:56 PM »
I installed it. However some graphic parts are not shown. Also above the buttons "Marked as read" there is something dark blue text, whats that?

« Last Edit: April 13, 2006, 08:12:14 PM by Bitwiz44 »

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midngight Ocean
« Reply #2 on: April 14, 2006, 06:26:11 AM »
Right, I've had a look at it and the only way I am able to reproduce the mess you are getting with the graphics is when the board is empty (no posts) when there are posts there it looks fine.  It does however need fixing as it shouldn't be doing that when it's empty either.  As to the blue text that appears to be who is viewing the board at that time.  I am withdrawing the 1.0.7 version of Midnight Ocen until I can fix these errors.

However I have noticed that you have a very large image in the logo area, is that just an oversized avatar or have you added a banner to the theme?  If you have added an image there yourself then you may have also added an extra column to the theme which has pushed everything to the right.

It would seem that the mess at the bottom is been cause by the quick moderation feature.  I will have a look into this and see if I can fix it.

Wolfenrook
« Last Edit: April 14, 2006, 07:22:27 AM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline Bitwiz44

  • Jr. Member
  • **
  • Posts: 123
  • Gender: Male
Re: Midngight Ocean
« Reply #3 on: April 14, 2006, 10:16:27 PM »
Right, I've had a look at it and the only way I am able to reproduce the mess you are getting with the graphics is when the board is empty (no posts) when there are posts there it looks fine.  It does however need fixing as it shouldn't be doing that when it's empty either.  As to the blue text that appears to be who is viewing the board at that time.  I am withdrawing the 1.0.7 version of Midnight Ocen until I can fix these errors.

However I have noticed that you have a very large image in the logo area, is that just an oversized avatar or have you added a banner to the theme?  If you have added an image there yourself then you may have also added an extra column to the theme which has pushed everything to the right.

It would seem that the mess at the bottom is been cause by the quick moderation feature.  I will have a look into this and see if I can fix it.

Wolfenrook
The Image is an Avatar. It looks big, however this is due to the way the screen capture worked. I did nothing to the theme. As you see is what I got after the install

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midngight Ocean
« Reply #4 on: April 15, 2006, 06:38:52 AM »
Oddness.  I tried it in IE with a bigger avatar and it didn't do that, so it's not that.  Most of the mess is been caused by the quick mod sections, I'm looking into that at the moment.  But the big gap to the left is a real mistery, I just can't get it to reproduce in IE 6, IE7, Opera 8.5, Opera 9 or Firefox.  But then it would have to be in IE that the problem is happening as looking at the graphics your theme has switched to the IE version of the style sheet (none IE browsers use a different stylesheet with png images instead of gifs.

I'll get it sorted then re-upload it.  I need to make some updates to the RC2 version as well anyway.
Thoughts are free, it's their consequences that often have a cost.

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midngight Ocean
« Reply #5 on: April 15, 2006, 09:15:59 AM »
I see your point! lol.  It's supposed to be Midnight Ocean, not Midngight Ocean!

Oh an further to the repairs, I believe I have fixed all the errors, although as I am unable to reproduce the one where the graphics have moved to the right I can not be sure about that.  Could well be however that the other fixes will fix that as well.

The 1.0.7 version is back up.

Wolfenrook.
Thoughts are free, it's their consequences that often have a cost.

Offline Bitwiz44

  • Jr. Member
  • **
  • Posts: 123
  • Gender: Male
Re: Midnight Ocean
« Reply #6 on: April 15, 2006, 10:12:57 AM »
Different- Issues now.


Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #7 on: April 15, 2006, 01:42:07 PM »
Did you delete the theme before re-installing (as in both in the admin cp, and via ftp (removing the actual files from the server)) as that isn't the updated theme you are posting screenshots of.

In IE the message.index should look like this:-



as the code has been changed quite a bit.  The screenshot you have posted is of the broken version of Midnight Ocean, not the fixed version that I uploaded today.

Wolfenrook
« Last Edit: April 15, 2006, 01:50:33 PM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline URPG

  • Jr. Member
  • **
  • Posts: 360
Re: Midnight Ocean
« Reply #8 on: May 22, 2006, 06:48:49 PM »
Demo Link not working :(

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #9 on: May 24, 2006, 06:09:58 AM »
Yeah I know, I had a problem with a hacker getting into my main site and one I hosted and destroying a load of content, so did a clean out.  I just haven't yet gotten around to re-installing my demo site as been too busy rebuilding my main site and restoring the database.

Wolfenrook
Thoughts are free, it's their consequences that often have a cost.

Offline Bitwiz44

  • Jr. Member
  • **
  • Posts: 123
  • Gender: Male
Re: Midnight Ocean
« Reply #10 on: May 25, 2006, 07:53:09 AM »
Wolf- it works now. Thank-you very much.

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #11 on: June 17, 2006, 06:44:59 AM »
No prob Bitwiz, the demo links are fixed now as well.  I just need to perform a few minor changes to the RC2 version now.  The 1.1 RC2 Version has now had some alteration made to fix the layout when using quickmod, and also now has a catbg2 type setup so that you can see if there are new posts in collapsed categories more easily.

Wolfenrook
« Last Edit: June 19, 2006, 12:36:28 PM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline CyberSongs

  • Semi-Newbie
  • *
  • Posts: 46
    • Music
Re: Midnight Ocean
« Reply #12 on: July 17, 2006, 02:37:22 AM »
Fatal error: Call to undefined function create_button() in <drive>:\<path>\SMF\Sources\Load.php(1040) : eval()'d code on line 249

After posting the first message.


Offline URPG

  • Jr. Member
  • **
  • Posts: 360
Re: Midnight Ocean
« Reply #13 on: July 18, 2006, 09:26:41 AM »
Demo Link still down :(

Can any other of you post your own Forum URL when you got it working? Do not need to see it on original site, but would like to see it in action before installing...

If all the small bugs are gone, have you thought about doing a TP version too? :-D

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #14 on: July 21, 2006, 02:04:51 PM »
You must have tried the demo links whilst I was moving my sites to a new server, should be up if you try it now.

I have indeed considered doing a TP version, but haven't gotten around to it yet as 1) been really busy and 2) I'm waiting for the current alpha version to be released in beta as 0.8.6 wont be the current version for much longer.

Oh and to respond to 2 comments made on the themes site:-

Samames, the images are very high quality, the jagged edges on the info centre are an optical illusion created by the background.  Unless you are using IE, in which case that is why you are seeing lower quality images as if you view the theme in IE it uses a different style sheet with gif images instead of pngs.  If you want to see this theme at it's best you need to use Opera or Firefox browsers.

matt -  How exactly do you think that a theme could cause a database error?  I have this theme running on 2 demo sites, with no database errors on either, and over 1000 downloads (this theme was downloaded more than 1000 times on my own themes site before I even launched it on here) with no other reports of database errors would support this.  I would suggest that you have something else on your site causing your database errors, or your hosts are overselling and have overloaded the MySQL server.

Wolfenrook
« Last Edit: July 21, 2006, 02:12:37 PM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #15 on: July 29, 2006, 04:42:32 PM »
Demo Link still down :(

Can any other of you post your own Forum URL when you got it working? Do not need to see it on original site, but would like to see it in action before installing...

If all the small bugs are gone, have you thought about doing a TP version too? :-D

Done, for both 0.86 and 0.95 with SMF1.1RC2 only though.  You can get the from the downloads section here and the demo for the TinyPortal version is on there as well, it's the default theme.

Wolfenrook
Thoughts are free, it's their consequences that often have a cost.

Offline Wolfenrook

  • Jr. Member
  • **
  • Posts: 297
  • Gender: Male
    • The Cottage
Re: Midnight Ocean
« Reply #16 on: July 29, 2006, 04:52:35 PM »
Fatal error: Call to undefined function create_button() in <drive>:\<path>\SMF\Sources\Load.php(1040) : eval()'d code on line 249

After posting the first message.



Load.php is not a file related to this theme at all, but rather a part of SMF itself.  Aparantly (thanks Sloopz) this is often an error caused when you use the wrong version of a theme for the version of SMF that you have, eg the 1.1RC2 version of this theme with SMF 1.0.7.  So please check that you have downloaded the correct version for your forum.

Wolfenrook
« Last Edit: July 29, 2006, 05:28:17 PM by Wolfenrook »
Thoughts are free, it's their consequences that often have a cost.

Offline URPG

  • Jr. Member
  • **
  • Posts: 360
Re: Midnight Ocean
« Reply #17 on: August 06, 2006, 12:23:17 PM »
Thanks, got it.

Offline ohioreef

  • Jr. Member
  • **
  • Posts: 119
Re: Midnight Ocean
« Reply #18 on: October 01, 2006, 03:12:12 AM »
Is this compatible with 1.1 RC3?

Offline ohioreef

  • Jr. Member
  • **
  • Posts: 119
Re: Midnight Ocean
« Reply #19 on: October 02, 2006, 08:36:27 AM »
I installed the theme and really like it. I did notice that there is no button linking to the member list. How can I add that button?

Also noticed that there is no 'My Messages' button.
« Last Edit: October 02, 2006, 08:47:03 AM by ohioreef »