• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 08:43:23 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Rename index.php

Started by Thantos, November 27, 2005, 11:17:01 PM

Previous topic - Next topic

Thantos

To rename the forum's index.php file do the following:

Rename the actual file.
Open QueryString.php in your Sources directory
Find $scripturl = $boardurl . '/index.php';
And change index.php to whatever filename you want.

Leipe Po

wahaahaha i really needed this, and withing 3 mouse clicks found it, good job and thank a bunch
There is only one thing more importend to me then coding:
My Girlfriend

Microsoft - "You've got questions.  We've got dancing paperclips."

Neol

What is the point of this?

Flying Drupalist

You can build other front pages! OMG THANKS!

babjusi

Thanks for this tip Thantos

Flying Drupalist

Really happy that Zeri YT bumped this. :D

jkay

How do I create a index page that is of the same template as my forum?

Thanks!

Osmonicar

Quote from: jkay on July 06, 2007, 05:00:04 AM
How do I create a index page that is of the same template as my forum?

Thanks!

Just copy the index.php I think?

Harro

You'll have to create it.
Take a look at this topic for a bit more information.

jkay

Thanks! I have successfully changed that. I need help with editing the link tree, any idea how I can do that?

http://www.simplemachines.org/community/index.php?topic=181497.msg1154676#msg1154676

Harro

Just replied in that topic. Let me know there if you still need help with it :)

heavyccasey

This was posted in 2005. Does it still work?

Dragooon


whosline07

Quick problem with this, I changed the line to use forums.php instead of index.php, and it did in fact change the url's for the link bar to the correct ones, however none of them work.  Any suggestions?

JBlaze

You have to rename index.php as well...
Jason Clemons
Former Team Member 2009 - 2012

whosline07

Sorry to not mention that, but I did that as well.

JBlaze

What version forum are you using? If you are using 2.0 you may have to clear your forum cache.
Jason Clemons
Former Team Member 2009 - 2012

whosline07

That appears to have solved it thanks a bunch.

JBlaze

Jason Clemons
Former Team Member 2009 - 2012

MF30


Advertisement: