Advertisement:

Author Topic: Out of range value adjusted for column 'numTopics' at row 1  (Read 13659 times)

Offline CapriSkye

  • Full Member
  • ***
  • Posts: 574
    • Open
Out of range value adjusted for column 'numTopics' at row 1
« on: November 07, 2005, 03:33:54 AM »
I think this has to do with MySQL 5...
I've seen this post, but there are too many files to edit so I gave up.
http://www.simplemachines.org/community/index.php?topic=50865.0

This following error is not the same error as above topic.
Whenever I try to remove a board, or a category, I get the following error:
Code: [Select]
Out of range value adjusted for column 'numTopics' at row 1
File: D:\website\capriskye\forums\Sources\RemoveTopic.php
Line: 293

I've tried with everything I know but still can't get rid of that.
I also found couple places if somebody wants to read up about it.
http://www.openwin.org/mike/index.php/archives/2005/02/using-strict-mode-to-make-not-null-safe/
http://sourceforge.net/mailarchive/forum.php?thread_id=8881499&forum_id=31882
http://db4free.blogspot.com/2005/10/web-apps-ready-for-mysql-5.html

Offline Compuart

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,774
  • Gender: Male
  • Zéeeeal
    • RealityNet
Re: Out of range value adjusted for column 'numTopics' at row 1
« Reply #1 on: November 07, 2005, 12:57:57 PM »
Try Admin -> 'Forum Maintenance' -> 'Recount all forum totals and statistics.'

I think that should solve the problem of not being able to delete boards and categories.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

Offline CapriSkye

  • Full Member
  • ***
  • Posts: 574
    • Open
Re: Out of range value adjusted for column 'numTopics' at row 1
« Reply #2 on: November 07, 2005, 01:06:02 PM »
now i feel like an idiot...
thanks!! solved

Offline NavyGuy

  • Newbie
  • *
  • Posts: 1
  • Gender: Male
Re: Out of range value adjusted for column 'numTopics' at row 1
« Reply #3 on: November 28, 2005, 02:45:57 PM »
Open up your MySQL configuration file and comment out the sql-mode line, it will disable the strict settings, which should make things work again :)
E-2 Delayed Entry Personnel Specialist,
U.S. Navy