Advertisement:

Author Topic: Error when upgrading from 1.1.14 to 2.0 final  (Read 2923 times)

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Error when upgrading from 1.1.14 to 2.0 final
« on: June 23, 2011, 03:36:24 PM »
Hi everyone.
So.. I'm trying to upgrade my version of smf from 1.1.14 to 2.0 and I'm doing this on a test forum first.. in order to see how things are going (Thanks God I've tryed this step on a test forum first... )
So.. I've made a backup to the entire forum, to the database using that feature insider forum and also from cPanel using Backup Wizard.
I've downloaded the large upgrade package, extracted the files and then uploaded them using Filezilla in the same folder (basically overwriting the old files).
Loaded http://www.mydomain.com/forum/upgrade.php, started the process and after a few steps... BOOM.. the error. I'm attaching you a pic with the error:


So.. where's the mistake ? How can I solve the error and complete the upgrade with success ?!

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #1 on: June 24, 2011, 12:02:43 PM »
Hmmm.. none able to respond here ?!

Offline phil_h

  • Newbie
  • *
  • Posts: 4
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #2 on: June 24, 2011, 02:12:21 PM »
I have a problem upgrading 1.14 -> 2.0 as well:

SMF Installer

 Warning: Cannot modify header information - headers already sent by (output started at /home/pchwebco/public_html/p_forum/webinstall.php:2) in /home/pchwebco/public_html/p_forum/webinstall.php on line 916

line 916 is:
      header('Location: http://' . (empty($_SERVER['HTTP_HOST']) ? $_SERVER['SERVER_NAME'] . (empty($_SERVER['SERVER_PORT']) || $_SERVER['SERVER_PORT'] == '80' ? '' : ':' . $_SERVER['SERVER_PORT']) : $_SERVER['HTTP_HOST']) . (strtr(dirname($_SERVER['PHP_SELF']), '\\', '/') == '/' ? '' : strtr(dirname($_SERVER['PHP_SELF']), '\\', '/')) . '/upgrade.php');

Does that make sense to anyone ?
An attempt to get 1.14 back fails with the same error.

Offline phil_h

  • Newbie
  • *
  • Posts: 4
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #3 on: June 24, 2011, 03:00:25 PM »
Well, I'm running 2 now.
I used fantastico to get 1.13 running then downloaded the zip and ran the upgrade script and all seems to be ok now.
Not impressed with 'SMF Installer' !

Offline b4pjoe

  • Jr. Member
  • **
  • Posts: 395
  • Gender: Male
    • B4print.com
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #4 on: June 24, 2011, 06:28:48 PM »
Hi everyone.
So.. I'm trying to upgrade my version of smf from 1.1.14 to 2.0 and I'm doing this on a test forum first.. in order to see how things are going (Thanks God I've tryed this step on a test forum first... )
So.. I've made a backup to the entire forum, to the database using that feature insider forum and also from cPanel using Backup Wizard.
I've downloaded the large upgrade package, extracted the files and then uploaded them using Filezilla in the same folder (basically overwriting the old files).
Loaded http://www.mydomain.com/forum/upgrade.php, started the process and after a few steps... BOOM.. the error. I'm attaching you a pic with the error:

So.. where's the mistake ? How can I solve the error and complete the upgrade with success ?!

I had that happen too. Just re-running the upgrade script and it went through it on the second try.

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #5 on: June 24, 2011, 09:46:01 PM »
I re-runned it 6 more times.. and still the same, believe me.

Do you guys have a proper solution for this problem ?
« Last Edit: June 25, 2011, 04:56:59 AM by Perspective »

Offline b4pjoe

  • Jr. Member
  • **
  • Posts: 395
  • Gender: Male
    • B4print.com
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #6 on: June 26, 2011, 01:24:29 AM »
Does it ever get past the 38% mark as shown in your earlier screen shot? If that percentage keeps going higher I would keep running it and see if it ever finishes.

Also maybe go into phpMyAdmin and repair all tables before trying the next time.

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #7 on: June 29, 2011, 09:00:47 PM »
Never gone above 38%. Simply stops there and that's all.
Anyways.. someone would consider me a  madman, but I've installed a clean 2.0 version, re-aded manually all 437 users and all 1800+ topics and boards by loging to each account and posting. After I've just put people to use remind feature in order to reset their passwords and login into forum. Of course.. this has a lot of disavatages like.. changing links for topics, changing date of posts, loosing all stats and so on, but I'll fix them in Google webmaster. But.. 1800 posts are relativelly not so many... the community will probably earnd thousands in a few years.

SMF Gold works great now, also the mods. I would recommend Hide Tag Special.. a very powerful mod. I'm not sure about Aeva on 2.0 version of SMF. Saw many with problems.. if not I have to find another mod that shows/inserts the youtube/google/vimeo player inside forum. Any ideas ?

Anyways.. I won't mark this topic as solved as far as none gave me a proper solutiion.

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #8 on: July 02, 2011, 06:33:42 PM »
Btw.. is there any way in which I can modify the stats? Would like to have old stats on this new installation.

Offline JimM

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,980
  • Gender: Male
    • Southern Spirit Hunters
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #9 on: July 13, 2011, 08:48:33 PM »
@ Perspective - Normally when you see that error, you just need to wait as it says and it will continue.  If it doesn't, you should click "here" and try that step again.  How long did you wait? 

Jim "JimM" Moore
Former Support Specialist

Please do not PM me for support!                   
Installing SMF
Upgrade SMF
Manual Installation of Mods

Offline Perspective

  • Semi-Newbie
  • *
  • Posts: 58
Re: Error when upgrading from 1.1.14 to 2.0 final
« Reply #10 on: September 20, 2011, 02:49:29 PM »
I solved it by myself.
Thanks for all answers!