Advertisement:

Author Topic: Forum Firewall  (Read 305703 times)

Offline JoeB

  • Jr. Member
  • **
  • Posts: 220
Re: Forum Firewall
« Reply #120 on: January 26, 2011, 08:53:17 AM »
You should not turn on banned until you are sure that you are not going to ban yourself.

I will send you a pm.


Thank you butches for rapid reply
I am confused...what ban?
Can you tell me exactley which one od those?
General Settings
--------------------------------------------------------------------------------
Enable Testing
Block Violations
Logging
Cache Duration
Notify Administrator
--------------------------------------------------------------------------------
DOS Attacks
--------------------------------------------------------------------------------
User-Agent Inspection.
DOS Attack
User-Agent Whitelist
Trigger (#/sec)
Longterm Ban
--------------------------------------------------------------------------------
IP Address
--------------------------------------------------------------------------------
Enable IP Validation
Enable Admin IP Confirmation
Admin IP Low
Admin IP High
Admin Domain Name
--------------------------------------------------------------------------------
Ports
--------------------------------------------------------------------------------
Enable Remote Port Validation
Enable Server Port Validation
Server Port List
--------------------------------------------------------------------------------
SQL Injection
--------------------------------------------------------------------------------
Enable Injection Test
Permitted URI Characters
--------------------------------------------------------------------------------
Cross-Site Scripting
--------------------------------------------------------------------------------
Enable XSS Inspection
XSS Events alert
--------------------------------------------------------------------------------
HTTP Header Attacks
--------------------------------------------------------------------------------
Enable Header Inspection
Referrer Attacks
User-Agent Attacks
Request Entity Attacks
Country Identification
--------------------------------------------------------------------------------
Enable Country Test
GeoIP
Country Code via Headers
Country
--------------------------------------------------------------------------------
Proxy Information
--------------------------------------------------------------------------------
Visitor IP call to ProxyProxy Header IDEnable Bypass ProtectionDomain NameIP Address

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #121 on: January 26, 2011, 09:01:51 AM »
You are lucky I am home sick.  Going back to work tomorrow.  :o

Turn off "Block Violations" for now.  Then fix the php files.

You probably blocked yourself with the "Enable Admin IP Confirmation".  The log will give you more details.  Read the help icons "?" for details on how to adjust.
« Last Edit: January 26, 2011, 09:05:33 AM by butchs »
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline henrik1782

  • Jr. Member
  • **
  • Posts: 252
  • SMF 2.0 RC5/Curve
Re: Forum Firewall
« Reply #122 on: January 26, 2011, 05:10:44 PM »
Hi...

This is not really a problem with Forum Firewall but...

I just updated from 1.02 to 1.04 and once more when updating or removing a mod I had to manually make changes. For me it seem that installation of mod is based more or less on search/replace and if another mod get in between your have to make manual install/uninstall. It is normally not a big issue I just wonder that there could have been implemented a better way to do this.

This is just a comment for my fustration... Forum Firewall i working just fine. Great work.
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #123 on: January 26, 2011, 05:41:13 PM »
The upgrade is worth it just for the obfuscation.  He he...  O:)

I think I am done for a while updating anyway...
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline henrik1782

  • Jr. Member
  • **
  • Posts: 252
  • SMF 2.0 RC5/Curve
Re: Forum Firewall
« Reply #124 on: January 26, 2011, 06:11:55 PM »
Hi Butch and Arantor...

I know that it is not a special issue for Forum Firewall and honestly I dont mind updating. It would just have been so much easier if SMF had implemented this in another way. There are tons of other way to do it and it just seems a litle bit cloomsy.

Ok ... this is just another topic... it was just my fustration  ;)
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #125 on: January 26, 2011, 07:40:58 PM »
One thing is to translate and other thing is to test.  ;)

We you did look at it and provide me a list of 1.1.x comments.  Like I did for you...  If you like I will can change you to reviewer or something like that?
 ???
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Dippster

  • Newbie
  • *
  • Posts: 2
Re: Forum Firewall
« Reply #126 on: January 27, 2011, 01:43:55 AM »
I was excited by this mod, it failed on test for index.template.php in default theme and ManagePermissions.php, but was OK with my theme by crip. I backed up the two pages and allowed the mod to install. once this was done I was redirected to the setup page and when ever i try to save I get a 406 error, even if i do nothing, and just try to save I get this error. I am using version 2.0 RC4.

Any help would be appreciated as I dearly would love to get this mod functioning on my forums.
Dippy

Offline henrik1782

  • Jr. Member
  • **
  • Posts: 252
  • SMF 2.0 RC5/Curve
Re: Forum Firewall
« Reply #127 on: January 27, 2011, 09:56:24 AM »
Hi Butchs....

just been excluded from my own forum. Acused of a DOS attack. How do I gain access again.
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

Offline Masterd

  • SMF Hero
  • ******
  • Posts: 3,920
  • Gender: Male
Re: Forum Firewall
« Reply #128 on: January 27, 2011, 01:12:27 PM »
Will this mod work with Simple SEF?

Offline Joazo

  • Jr. Member
  • **
  • Posts: 159
Re: Forum Firewall
« Reply #129 on: January 27, 2011, 02:29:53 PM »
Hi Butchs....

just been excluded from my own forum. Acused of a DOS attack. How do I gain access again.

All settings can be edited in the SMF_"settings" file in phpmyadmin.  Find "forumfirewall_enable" and change it from 1 to 0, refresh the browser and re-enter the admin panel and fix the settings in the mod.

Offline henrik1782

  • Jr. Member
  • **
  • Posts: 252
  • SMF 2.0 RC5/Curve
Re: Forum Firewall
« Reply #130 on: January 27, 2011, 03:07:38 PM »
Thanks Joazo..
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

Offline Joazo

  • Jr. Member
  • **
  • Posts: 159
Re: Forum Firewall
« Reply #131 on: January 27, 2011, 05:42:55 PM »
About ports:
Port 80 is enough in the allowed ports list or need anything more?

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #132 on: January 27, 2011, 07:03:36 PM »
I was excited by this mod, it failed on test for index.template.php in default theme and ManagePermissions.php, but was OK with my theme by crip. I backed up the two pages and allowed the mod to install. once this was done I was redirected to the setup page and when ever i try to save I get a 406 error, even if i do nothing, and just try to save I get this error. I am using version 2.0 RC4.

Any help would be appreciated as I dearly would love to get this mod functioning on my forums.
Dippy

I really do not what to tell you.  You installed an unknown custom theme and tried to install the mod even after getting errors.  Not a good idea.  The mod is designed for the default theme and when using a custom there you need to perform a manual installation of the mod.  First install it in your default theme, then edit the parts of the custom theme that apply. :'(
« Last Edit: January 27, 2011, 07:17:02 PM by butchs »
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #133 on: January 27, 2011, 07:05:11 PM »
About ports:
Port 80 is enough in the allowed ports list or need anything more?

In most cases port 80 is all you need for SMF. :)
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #134 on: January 27, 2011, 07:11:57 PM »
Will this mod work with Simple SEF?

Out of the box, I have no idea.  The best part about this mod is that is is totally Admin configurable.  So I believe FF can be adjusted to work by editing the settings.
 :-X
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Masterd

  • SMF Hero
  • ******
  • Posts: 3,920
  • Gender: Male
Re: Forum Firewall
« Reply #135 on: January 28, 2011, 04:38:01 AM »
Thank you, anyway. I will try this out.

Offline henrik1782

  • Jr. Member
  • **
  • Posts: 252
  • SMF 2.0 RC5/Curve
Re: Forum Firewall
« Reply #136 on: January 28, 2011, 07:23:54 PM »
Hi Butchs

I have about one user every day which is blacklistet because of DOS attack. Se attachment

Can you advice to lower the DOS attack trigger from 0.65 to maybe 0.5.

Best regards
Henrik Poulsen
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #137 on: January 28, 2011, 07:38:19 PM »
Lowering it will cause it to be more restrictive.  Raising the attack trigger will make it less restrictive.

If you read the built in help the trigger is the hits per second over the cache duration. So if you take the cache duration and multiply it by the trigger that will give you the total hits over the cache duration.

I really do not think raising it is a good idea.  Why not whitelist your top members instead?

I find it hard to believe that regular members are getting banned because they have to click a whole bunch of times to access the trigger.  Maybe there is another mod over using the "actionArray" causing the bans.

For example if you read post #69 in this thread the enotify mod was causing users to get banned.  The problem was reduced when the refresh rate was changed from 10000 to 30000.  Maybe it needs to be higher?
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Dippster

  • Newbie
  • *
  • Posts: 2
Re: Forum Firewall
« Reply #138 on: January 29, 2011, 02:16:25 AM »
I was excited by this mod, it failed on test for index.template.php in default theme and ManagePermissions.php, but was OK with my theme by crip. I backed up the two pages and allowed the mod to install. once this was done I was redirected to the setup page and when ever i try to save I get a 406 error, even if i do nothing, and just try to save I get this error. I am using version 2.0 RC4.

Any help would be appreciated as I dearly would love to get this mod functioning on my forums.
Dippy


I really do not what to tell you.  You installed an unknown custom theme and tried to install the mod even after getting errors.  Not a good idea.  The mod is designed for the default theme and when using a custom there you need to perform a manual installation of the mod.  First install it in your default theme, then edit the parts of the custom theme that apply. :'(

Barbones forum, no other mods, no other themes complete install from scratch, bad behaviour works fine but still get 406 error when I click the save button in Forum Firewall settings. any ideas?


Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,728
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Forum Firewall
« Reply #139 on: January 29, 2011, 09:47:03 AM »
Do you have any thing in the SMF Error log?  If not, my guess it is on your server side and has nothing to do with the mod.

It could be the security settings by your host (ie using Modsecurity in Apache).  Or it could be a hosts firewall is blocking the content; if so, you will need to edit the mod settings in phpmyadmin.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.