News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

IE8 and the jumping scrollbar

Started by Mr. Jinx, June 30, 2010, 02:03:01 PM

Previous topic - Next topic

Mr. Jinx

In IE8 there seems to be a bug with the textbox. If you post a message, and the textbox is full, the slider on the right goes nuts and you will see your text jumping around.

I have seen multiple reports about this problem, but still no fix or workaround?

What I don't get is that other forums do not have this problem, or at least say they have fixed it.
Also, the quickreply textbox works perfect. It's only the normal textbox when replying that has this strange bug.

I know some will anser 'use a real browser' but you just cannot ask all users to switch browser. It would be nice, but not gonna happen.

CapadY

Please, don't PM me for support unless invited.
If you don't understand this, you will be blacklisted.

mirahalo

Quote from: capady on June 30, 2010, 03:16:08 PM
What SMF version ?

well,  since he post on the 2.0 board and that "bug" has to do with the wysiwyg editor, I would guest 2.0 ;)  and yes, there has been multiple posts/report on this one.

CapadY

Quote from: 130860 on June 30, 2010, 03:23:14 PM
Quote from: capady on June 30, 2010, 03:16:08 PM
What SMF version ?

well,  since he post on the 2.0 board and that "bug" has to do with the wysiwyg editor, I would guest 2.0 ;)  and yes, there has been multiple posts/report on this one.

Oke, more specific:

  • SMF2rc1
  • SMF2rc1.1
  • SMF2rc1.2
  • SMF2rc1.3
  • SMF2rc2
  • SMF2rc3

Or maybe one of the beta's of SMF2 ?????

Please, don't PM me for support unless invited.
If you don't understand this, you will be blacklisted.

YogiBear

Plus how Microsoft are notorious for going their own way with little or no consultation with other makers of software.

IE8 can cause a number of odd effects but running it in IE7 Compatability Mode fixes most.
SMF v2.0.19  Mods : Ohara YouTube Embed v1.2.9,  Custom Tab v1.2 , Bakers' Dozen Pages v1.2 , SMFPacks Shoutbox v1.1,  Board Color & Icons v1.1 , Simple Image Upload , Snow & Garland v1.4,  PHP  v.7.4.25

Mr. Jinx

This is with SMF 2.0 RC3
I did force the compatability mode a while ago, but then there where other problems like layout glitches etc.
I think that is not the way to go.

Antechinus

As far as I know using compatibility mode is the only workaround at the moment.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Jakob Fel

IE8 is not very good with SMF. :P Actually,  IE altogether is stupid in my opinion.  ;D I unfortunately can't think of anything that could help that.
Freelance writer, entrepreneur-in-training and DRM-free advocate
Support and Community Management at SMFNew Free Forum Hosting

Herman's Mixen

Open index.template.php and add this code between the <HEAD>..</HEAD> tags

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Antechinus

Doesn't work any more. They changed IE8 and that code apparently screws things up now. I used to use it on my site and found that it wasn't working after a while.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Herman's Mixen

Well still works for me :P

see http://msdn.microsoft.com/en-us/library/cc288325%28VS.85%29.aspx

IE8 and IE9 are still a pain in the ass... just use more than 1 crappy browser

FireFox
Opera
K-melon
maxthon
Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Antechinus

Weird. Guys on my site using IE8 were grumbling that the cursor had started jumping again, so I had to ditch that code and get them to use compat mode. Only thing that worked for them.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz


Antechinus

That topic says what I just said: meta tag is broken, use compat mode. ;)
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

[SiNaN]

Quote from: Mr. Jinx on June 30, 2010, 04:07:42 PM
This is with SMF 2.0 RC3
I did force the compatability mode a while ago, but then there where other problems like layout glitches etc.
I think that is not the way to go.

What kind of "layout glitches" have you seen, except for the broken footer? Screenshots would help a lot by the way.
Former SMF Core Developer | My Mods | SimplePortal

thc1967

Quote from: [SiNaN] on July 02, 2010, 11:04:47 AM
Quote from: Mr. Jinx on June 30, 2010, 04:07:42 PM
This is with SMF 2.0 RC3
I did force the compatability mode a while ago, but then there where other problems like layout glitches etc.
I think that is not the way to go.

What kind of "layout glitches" have you seen, except for the broken footer? Screenshots would help a lot by the way.

I see issues with list bullets.  Take this code for example:

[list]
[li]Bullet one[/li]
[li]Bullet two[/li]
[li]Bullet three[/li]
[/list]


One would expect there to be a little round dot in front of 3 lines of text.  But on IE8 in compatibility mode, the bullets aren't there.  The lines of text are there and they're left-justified.

Mr. Jinx

So there is no workaround for this?
Advising all users to use compatibility mode is not the way. Then they should use IE7 instead of IE8.
How is other forum software handling with this bug?
I know ip.board for example doesn't have this problem.

Antechinus

That one is fixed in svn. This is all it needs >

.bbc_list
{
   text-align: left;
}
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Mr. Jinx

This should solve the jumping scrollbar while typing / editting a message?
I tried it, but didn't see any improvement.

Masterd

Quote from: Antechinus on June 30, 2010, 07:06:24 PM
Doesn't work any more. They changed IE8 and that code apparently screws things up now. I used to use it on my site and found that it wasn't working after a while.

Yes, but there is special mode for emulating IE7 in IE8. 

Advertisement: