News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Googlebot & Spiders

Started by Omar Bazavilvazo, June 06, 2005, 06:17:35 PM

Previous topic - Next topic

Omar Bazavilvazo

Link to Mod

Last Updated: Sep 23, 2010

This Mod allows to see on Boardindex & SSI, when the spiders are crawling the forum. Also spiders that visit your forum using PHPSESSID URLs, and displays on your pages when google last visited them.

Multiple options can be set, and is based on permissions, also.

Is STRONGLY recommended to install this file also (Custom Who.template.php - Displays Users, Guests & Spiders):
http://www.simplemachines.org/community/index.php?topic=401980.0

Questions about problems installing the mod in the mod topic:
http://www.simplemachines.org/community/index.php?topic=38003.0

Version 2.0.4 works with 1.1.x and TinyPortal 0.9.8

NEW ON V2:
Redirect PHPSESSIDs: When a spider comes with a URL like this:
http://hablajapones.org/foro/index.php?PHPSESSID=843ac3340412047023e1b2a557bfadbe
The mod will redirect with a "HTTP/1.1 301 Moved Permanently", to the correct URL that will be:
http://hablajapones.org/foro/index.php
GoogleStats: On each page will display when was last googlebot visit.

Thanks to this sites for the info that I used to create this new modifications on V2:
http://www.ragepank.com/articles/26/disable-phpsessid/
http://www.fabriziotarizzo.org/wiki/Wikka/WpGooglestats

Here are some screenshots:
















About Most Online

Until now it had this:


Changing:


Now we get:


Permissions:

Disallowed for guests:



Allowed for guests:



GoogleStats:


History:
23/Sep/2010 - 2.0.4 - Updated link to Custom Who.template.php by MoreBloodWine
5/Oct/2008 - 2.0.4 - Made it more mod-friendly, added a missing spanish string
23/Apr/2007 - 2.0.3 - Fixed some errors (not saving options)
9/Apr/2007 - 2.0.3 - FINALLY UPDATED FOR 1.1.X, fixed some problems when uninstalling mod, updated to work with TP 0.9.8, and made it compatible with SMF Package Parser Server for manual install
9/Sep/2006 - 2.0.2 - Fixed 'start' error, and checked compatibility with TP 0.9.5.
5/Sep/2006 - 2.0.1 - Fixed a small bug that topic wasn't being counted.
5/Sep/2006 - 2.0.0 for 1.1 RC3 and 1.0.8. No compatible with TinyPortal, becausethey have not released TP for this SMF versions. Added Redirect PHPSESSID and GoogleStats.
24/Feb/2006 - 1.0.5 for 1.1 RC2 updated to be compatible with TinyPortal
24/Feb/2006 - 1.0.5 Updated for 1.0.6 and 1.1 RC2
10/Nov/2005 - 1.0.4 Updated for 1.1 RC1
5/Jul/2005 - 1.0.4 Updated for 1.1 Beta 3 Public
24/Jun/2005 - 1.0.4 Fixed an error that in action=trackip;searchip=xx.xx.xx.xx gave the error Undefined index: ob_googlebot_count_most_online
24/Jun/2005 - 1.0.3 Released for 1.0.5
14/Jun/2005 - 1.0.2 Released for 1.1 beta 3
17/Jun/2005 - 1.0.2 Released for 1.0.x & 1.1 Beta 2
  6/Jun/2005 - 1.0.1 Released
  Fixed: error in filename case (Boardindex)
  6/Jun/2005 - 1.0.0 Released

じゃね!




Personal Signature:
HablaJapones
http://hablajapones.org
http://hablajapones.org/tutoriales.php


NO me manden PM para soporte o dudas
...Leo los foros como todos...

Grudge

Nice, I bet a lot of people will appreciate this mod.
I'm only a half geek really...

SusanTN

#2
Ok one bug.

   <file name="$sourcedir/Boardindex.php">
and
   <file name="$themedir/Boardindex.template.php">

should be

   <file name="$sourcedir/BoardIndex.php">
and
   <file name="$themedir/BoardIndex.template.php">

I unzipped the file and manually made the change and the mod installed perfectly.

1MileCrash

#3
yeah. Is that why it said "FILE NOT FOUND"? twice?

cool mod though. I like it. Props.

I tried it again...it still didnt work. Did you put the corrected file on the mod page yet?  :P
The only thing php can't do is tell you how much milk is left in the fridge.



Omar Bazavilvazo

Fixed, sorry for the problems...

I packaged it on Windows, so never noticed.

v1.0.1 up & running :)




Personal Signature:
HablaJapones
http://hablajapones.org
http://hablajapones.org/tutoriales.php


NO me manden PM para soporte o dudas
...Leo los foros como todos...

1MileCrash

Perfect Installation! Thanks. Awesome mod. I want my forums to be spider f00d  :P
The only thing php can't do is tell you how much milk is left in the fridge.



dtm.exe

Great mod!  I've been anticipating this one since you mentioned it.

-Dan The Man

MichiganMinis

Great, I love this already.

diplomat.

i have been waiting on this also. great mod man :)
avidSOUND.com: Where Aspiring Musicians Can Be HEARD!

Owdy

Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

Omar Bazavilvazo

* Omar Bazavilvazo bows to all his Mod users :)





Personal Signature:
HablaJapones
http://hablajapones.org
http://hablajapones.org/tutoriales.php


NO me manden PM para soporte o dudas
...Leo los foros como todos...

rmb

#11
I tryed to install but I get this error:

2: fopen(SSI.php): failed to open stream: Permission denied
File: /var/www/html/usd/Sources/Subs-Package.php
Line: 1476


So, what must I do now?

Thank you for answer.

SusanTN

Quote from: rmb on June 07, 2005, 01:17:49 AM
I tryed to install but I get this error:

./Sources/ManagePermissions.php Failure

So, what must I do now?

Thank you for answer.

On your packages list you have

#. Googlebot & Spiders Mod 1.0.1   [ Apply Mod ] [ List Files ] [ Delete ]

Click on List files

You should get a list like the one below. Select the one in bold.

List files in package
Files in archive Googlebot_v1.0.1.zip:
install.txt (357 bytes)
install.xml (12918 bytes)
package-info.xml (575 bytes)
SMF Mod TOS Draft.doc (21504 bytes)
[ Back ] 


You will now have a list of the changes the mod is susposed to make.

Search down the page until you see

   <file name="$sourcedir/ManagePermissions.php">

Find the below lines in your forum copy of Manage Permissions.php they should be in there somewhere

                                                )
                                ),
                                'board' => array(
                                                'general_board' => array(


Make the lines in your ManagePermissions.php match lines from the install.xml it should look like the text in the code section above and try to reapply the mod.

If it still fails. Uninstall all installed mods and replace the ManagePermissions with the original one from the smf_1-0-3_install.tar.gz then try installing the spiders mod first. Then simply reinstall the rest of your mods. If it still doesn't work you might wanna try a fresh install.

rmb

Now is ... confusing... Under "View and Remove Installed Packages" I do not heave this mod, but main page looks like this [nofollow]

What must I do now to repair this mod to work?

SusanTN

Quote from: rmb on June 07, 2005, 02:13:39 AM
Now is ... confusing... Under "View and Remove Installed Packages" I do not heave this mod, but main page looks like this

What must I do now to repair this mod to work?


Sounds like a permissions issue. Fix that and you should see the mod. Basically the mod is not visible to the web server. Try uploading the mod from your computer though the admin panel.

rmb

I reinstall all sources but when I try to install this mod I get from begining:

1. Execute Modification ./Sources/BoardIndex.php Failure
2. Execute Modification ./Sources/ManagePermissions.php Failure
3. Execute Modification ./Sources/ModSettings.php Success
4. Execute Modification ./Sources/Subs.php Failure
5. Execute Modification ./Themes/default/languages/Modifications.english.php Success
6. Execute Modification ./Themes/default/BoardIndex.template.php Success
7. Execute Modification SSI.php Success

I chmoded all files on 777, if I proceed I get on the end error in Subspackage.php

I simply cann not install this mod.


rmb

Without installed mod I heave on main page:

Users Online
  1 Spider, 1 Spider, 3 Guests, 2 Users
Users active in past 15 minutes:
administrator, 5.0L, Yahoo spider, Yahoo spider 


SusanTN

Taking this to private message so we don't spam this thread.

CokeCan

I installed it but when I go to "Edit Features and Options" I get this error:
QuoteParse error: parse error, unexpected T_ARRAY in /www/docs/forum/Sources/ModSettings.php on line 356
What should I do?

Harro

Nice work, been waiting for this :)

Got one problem tough. It's a bit hard to install it manualy. xml file isn't realy easy to follow, and it's very easy to overlook something.

Advertisement: