• Welcome to Simple Machines Community Forum. Please login or sign up.
October 21, 2021, 01:48:30 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


SMF 1.0.4 released

Started by Grudge, June 05, 2005, 09:34:16 AM

Previous topic - Next topic

Grudge

June 05, 2005, 09:34:16 AM Last Edit: June 08, 2005, 05:59:19 PM by [Unknown]
Simple Machines is happy to release the latest update to SMF. This is only a small release, which addresses an issue with the parsing of some BBC, and fixes a few minor bugs found since 1.0.3. While this is only a small release we strongly suggest that you upgrade to this version, because it will improve the security of your forum.

What's Changed:

  • fixed an issue with parsing embedded BBC tags
  • added "Update Available" information to the admin center, to notify admins of future updates
  • fixed a couple of minor bugs

As always, we would appreciate if you give us constructive feedback about this release, as well as bug reports.

If you are upgrading from 1.0.3, the easiest way to update is through the package manager. If not, you only need to use the "update" package as it includes only the changed files since 1.0's release. However, if you have any mods installed it would be better to use the "upgrade" package because it contains all the files for an SMF installation. Remember that you can use the "upgrade" package to come from any previous version of SMF, as well as from YaBB SE 1.5.1 or higher.

http://www.simplemachines.org/download.php

Thanks,
Simple Machines
I'm only a half geek really...

Trekkie101

Upgraded, two seconds it took.

IamV

I just installed the upgrade & immediately everyone's signatures turned into just the tagged urls

[img]url is here[/img]

sudden


Gary

I'll have my related sites (not mine thats on Beta 2 ;) ) upgraded ASAP.
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

dtm.exe

Oh, wow!  Awesome!  I'm updating now :).

-Dan The Man

mennou


IamV

Does anyone have any ideas how I can fix this problem with sigs on my site?

Gary

The upgrade worked without a hitch via the Package Manager. (I'm an admin on someones forum who is using the public release)
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

dtm.exe

Just got done upgrading one of my forums.  Was a complete success :).

-Dan The Man

dtm.exe

Quote from: IamV on June 07, 2005, 04:53:02 PM
Does anyone have any ideas how I can fix this problem with sigs on my site?

I'm not having this problem :-\.  Go to Admin > Edit Features and Options and make sure that the image tags are not in the "Disabled BBC Code (comma separated)" field.

-Dan The Man

mennou

same here  

Mixspot.com | Powered by SMF 1.0.4.
© 2001-2005, Lewis Media. All Rights Reserved.  
Page created in 0.098 seconds with 16 queries.

[Unknown]

Quote from: IamV on June 07, 2005, 04:53:02 PM
Does anyone have any ideas how I can fix this problem with sigs on my site?


Are you sure you don't have any disabled bbc?  What mods do you have installed?

Quote from: Naiden on June 07, 2005, 04:51:30 PM
I get this:

2: copy(/home/blabla/public_html/foro/changelog.txt~): failed to open stream: Permission denied
Archivo: /home/blabla/public_html/foro/Sources/Subs-Package.php
Línea: 1307

Make the "foro" directory writable.

-[Unknown]

pasargad

Do I have to take a backup of the site before the uppgrade? What are the requirements for the uppgrade will work and not cause any problem?

My forum has grown and I do NOT want to lose the whole.

Best regards

Owdy

Quote from: Naiden on June 07, 2005, 04:51:30 PM
I get this:

2: copy(/home/blabla/public_html/foro/changelog.txt~): failed to open stream: Permission denied
Archivo: /home/blabla/public_html/foro/Sources/Subs-Package.php
Línea: 1307
http://www.simplemachines.org/community/index.php?topic=38096.msg278445#msg278445
Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

mennou


[Unknown]

Quote from: pasargad on June 07, 2005, 05:05:26 PM
Do I have to take a backup of the site before the uppgrade? What are the requirements for the uppgrade will work and not cause any problem?

My forum has grown and I do NOT want to lose the whole.

I would suggest backing up if you got an itch.  Or if you had to go to the bathroom for a moment.  Backing up is not something we, or at least I, will ever say you should not do :P.

No requirements.  If SMF 1.0.3 works, and you weren't using the "Faster Parsecode" mod, it should be fine.  With that mod, you'll have problems updating.

-[Unknown]

mennou

my  ([img]/img]  )don't show up  .. how can  i fix that??  check my main site www.mixspot.com roll lil bit down  

Gary

Most of the time, not alot will happen when you upgrade, but you never know when something can go wrong, its better to back-up as you can never predict what will happen.
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

IamV

Quote from: [Unknown] on June 07, 2005, 05:09:34 PM


No requirements.  If SMF 1.0.3 works, and you weren't using the "Faster Parsecode" mod, it should be fine.  With that mod, you'll have problems updating.

-[Unknown]

That answers where my prob is ...

I just double checked and bbc is not disabled, plus sigs were working right before I upgraded.

I have:
unsend pm
buddy list
visual warning
enhanced quick reply
spam-me-not
New Topic/Poll buttons
OnLine Users Today
Inactive Members Groups mover
G&S sticky
Faster Parsecode
No Changing Moderator's Edit
Experience bar


how do I fix it now?  lol

Advertisement: