News:

Join the Facebook Fan Page.

Main Menu

Remove poll

Started by Tim, December 29, 2009, 09:33:22 AM

Previous topic - Next topic

romper

It should be solved with this but it isn't in my case...I tried manualy fixing it, and the diffrence is:
';sesc='...where I have ";sesc='... but if I try to change theme collapses?

JimM

You shouldn't have a double quote on that line.  Copy about 5 lines before and 5 lines after and post it here.
Jim "JimM" Moore
Former Support Specialist

romper

Here it is from my default theme:

   'lock' => array('test' => 'can_lock', 'text' => empty($context['is_locked']) ? 'smf279' : 'smf280', 'image' => 'admin_lock.gif', 'lang' => true, 'url' => $scripturl . '?action=lock;topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id']),
      'sticky' => array('test' => 'can_sticky', 'text' => empty($context['is_sticky']) ? 'smf277' : 'smf278', 'image' => 'admin_sticky.gif', 'lang' => true, 'url' => $scripturl . '?action=sticky;topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id']),
      'merge' => array('test' => 'can_merge', 'text' => 'smf252', 'image' => 'merge.gif', 'lang' => true, 'url' => $scripturl . '?action=mergetopics;board=' . $context['current_board'] . '.0;from=' . $context['current_topic']),
      'remove_poll' => array('test' => 'can_remove_poll', 'text' => 'poll_remove', 'image' => 'admin_remove_poll.gif', 'lang' => true, 'custom' => 'onclick="return confirm(\'' . $txt['poll_remove_warn'] . '\');"', 'url' => $scripturl . '?action=removepoll;topic=' . $context['current_topic'] . '.' . $context['start'] . ";sesc=" . $context['session_id']),
      'calendar' => array('test' => 'calendar_post', 'text' => 'calendar37', 'image' => 'linktocal.gif', 'lang' => true, 'url' => $scripturl . '?action=post;calendar;msg=' . $context['topic_first_message'] . ';topic=' . $context['current_topic'] . '.0;sesc=' . $context['session_id']),
   );

   if ($context['can_remove_post'] && !empty($options['display_quick_mod']) && $options['display_quick_mod'] == 1)
      $mod_buttons[] = array('text' => 'quickmod_delete_selected', 'image' => 'delete_selected.gif', 'lang' => true, 'custom' => 'onclick="return confirm(\'' . $txt['quickmod_confirm'] . '\');" id="quickmodSubmit"', 'url' => 'javascript:document.quickModForm.submit();');

Matthew K.


Caesarrrrr

I sometimes get this error when just logging out

romper

Quote from: Labradoodle-360 on February 12, 2010, 11:09:03 AM
My mod, Fix Session Verification for Polls fixes this issue.

Tried, nothing changes either in default theme or others, then mannualy tried and can't move " or everyting collapses...strange and anoying problem.


....just realized where could be a problem...I have additional polls mod installed, could that be a reason?

Arantor

Yes, I don't think additional polls has been fully updated for 1.1.11.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

JimM

Quote from: romper on February 12, 2010, 01:46:44 PM
....just realized where could be a problem...I have additional polls mod installed, could that be a reason?

That would probably be the issue.  You might check with the mod author to see if there are plans to update it for 1.1.11.
Jim "JimM" Moore
Former Support Specialist

romper

And of course no uninstall option just delete of the mod....so I have to do it mannualy, but pretty confident that was the issue.

JimM

Yep, the uninstall option disappears when you upgrade the forum.  If this is solved, please mark it solved by clicking the Mark Topic Solved link at the bottom left.
Jim "JimM" Moore
Former Support Specialist

Rehash D Internet

Hello there.

The code in the display.template of the theme I'm using is a little difference.

if ($context['can_remove_poll'])
$moderationButtons[] = '<a href="' . $scripturl . '?action=removepoll;topic=' . $context['current_topic'] . '.' . $context['start'] .'" onclick="return confirm(\'' . $txt['poll_remove_warn'] . '\');">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/admin_remove_poll.gif" alt="' . $txt['poll_remove'] . '" border="0" />' : $txt['poll_remove']) . '</a>';


Could you tailor your solution to fit this too please?

Appreciate your help.

Matthew K.

@Rehash D Internet - I have done this for you on my mods support topic.

Labradoodle-360

Sincere

Quote from: mizuno151 on January 22, 2010, 03:52:08 PM
i've fixed it!!!

open Themes\default\Display.template.php

find this


'url' => $scripturl . '?action=removepoll;topic=' . $context['current_topic'] . '.' . $context['start']),

replace with

'url' => $scripturl . '?action=removepoll;topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id']),

You are a star! it is people like you who make the difference.
Do you need a special mod for your smf forums? contact me for a quote.

JimM

This topic does contain the solution, thus I am marking it solved.
Jim "JimM" Moore
Former Support Specialist

Sincere

Quote from: JimM on September 25, 2010, 05:09:53 PM
This topic does contain the solution, thus I am marking it solved.

indeed it does, and it is such an easy and fast solution. thank you for that.

Do you need a special mod for your smf forums? contact me for a quote.

BigMike

mizuno151: Thank you for this fix. Saved me a lot of time

Advertisement: