• Welcome to Simple Machines Community Forum. Please login or sign up.

cant install or uninstall packages

Started by Afro, November 13, 2009, 05:59:16 AM

Previous topic - Next topic

Afro

November 13, 2009, 05:59:16 AM Last Edit: November 13, 2009, 06:03:41 AM by Afro
i get this error each time i try to install or uninstall a package


9.     Execute Modification     install.xml     Modification parse error
   10.    Execute Modification    install.xml    Modification parse error


then this in the error log

Apply Filter: Only show the error messages of this URL
http://www.afrowall.com/index.php?action=admin;area=packages;sa=install2;package=sitemap_2.1.0.zip;pid=0
Apply Filter: Only show the errors with the same message
2: require(/var/www/vhosts/afrowall.com/httpdocs/Packages/temp/./add_settings.php) [<a href='function.require'>function.require</a>]: failed to open stream: Success
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/afrowall.com/httpdocs/Sources/Packages.php
Line: 957

sshahnawaz

Install and Upgrade Help is not the relevant board for this by the way. Anyhow, what is your version of SMF and what does your forum error log say about it? Also check your permissions of packages, is this directory writable?
How to Make Money Online - Urdu Description https://www.youtube.com/watch?v=0Deggh2ZxNE

Afro

this is the error in the package manager


   1.     Execute Modification     install2.xml     Modification parse error
   2.    Execute Modification    install2.xml    Modification parse error
   3.    Extract File    ./PortalStandalone.php    
   4.    Extract Tree    ./Sources    
   5.    Extract Tree    ./Themes    
   6.    Extract Tree    ./Themes/default/languages    
   7.    Extract Tree    ./Themes/default/images/sp    
   8.    Extract Tree    ./Themes/default/images/admin    
   9.    Extract File    ./Themes/default/css/portal.css    
   10.    Extract File    ./Themes/default/css/portal_rtl.css    
   11.    Extract File    ./Themes/default/scripts/portal.js    
   12.    Adapt Database    install2.php







IF I TRY TO FORCE THE INSTALLATION, IT SHOWS A WHITE PAGE AND WONT INSTALL

sshahnawaz

I have asked about the forum error log. Does your forum have no error log?
How to Make Money Online - Urdu Description https://www.youtube.com/watch?v=0Deggh2ZxNE

Afro

you can see it on the first post.
i posted it there from the start

Windy

What's the mod your attempting to install?
Is the issue only with this mod, do you have any issues installing other mods?
All unsolicited PM's will be ignored.  Any support requests should go in their topics.

My Mods


Image Zoom Tag
Image Quote Removal
Color Picker
Additional Polls
Simple Awards System

Mods are only updated to the latest same major version of smf on request.

N3RVE

November 13, 2009, 01:55:05 PM #6 Last Edit: November 13, 2009, 02:00:55 PM by [n3rve]
By design, SMF is programmed to generate a "temp" folder under ./Packages in the SMF directory when you attempt mod installation. This aids package installation as the content of the package is extracted into this temporary directory (./Packages/temp) so the files can be read and the applicable changes applied.

In your case, perhaps due to the server configuration, SMF is unable to generate this directory, hence the modification parse error. In cases like this, you have to manually create the "temp" directory under ./Packages and chmod (How do I chmod? / what is chmod?) the folder accordingly.

I should add that the "temp" directory will be deleted upon completion of package installation and would need to be recreated whenever you want to install a package. However, you can install a little hack that would slay SMF's ability to do this. Let us know if you require additional assistance :).

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Afro

Thanks man but that didnt solve it.
Every mod i want to install returns the same error.
globalheaders and footers returned this : 
        1.     Execute Modification     globalhf2.xml     Modification parse error
   2.    Execute Modification    globalhf2.xml    Modification parse error


simple portal returned this :
       1.     Execute Modification     install2.xml     Modification parse error
   2.    Execute Modification    install2.xml    Modification parse error

ITS Apparently something about .xml

if i try to uninstall a previous installed mod, it returns the same .xml error.

N3RVE

Did you chmod the folder after creating it? You should give it 755, 775 or 777 depending on the server environment. Feel free to send me a temporary administrative account as well as an FTP account to resolve the issue.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Afro


nwobhm

I have bit similiar problem after upgrading my forum to RC2.
I cannot install any mods via package manager says that my package folder is not writable. I have chmodded all folder into 777 but still  I cannot install any mods.
I uploaded mods manually via FTP, but that did no good.

Afro

lets hope arantor will helps us out with it.

N3RVE

Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Advertisement: