Advertisement:

Author Topic: Upgrade from 1.1.9 to 1.1.10 failed  (Read 9796 times)

Offline forefront

  • Newbie
  • *
  • Posts: 9
Upgrade from 1.1.9 to 1.1.10 failed
« on: July 14, 2009, 10:31:16 PM »
After several years of flawless updates and upgrades, I ran into this today ...

Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./index.php    Test successful
2.    Execute Modification    ./Sources/ManageAttachments.php    Test successful
3.    Execute Modification    ./Sources/ManageBans.php    Test successful
4.    Execute Modification    ./Sources/ManageRegistration.php    Test failed
5.    Execute Modification    ./Sources/Packages.php    Test failed
6.    Execute Modification    ./Sources/PersonalMessage.php    Test failed
7.    Execute Modification    ./Sources/Post.php    Test successful
8.    Execute Modification    ./Sources/Profile.php    Test successful
9.    Execute Modification    ./Sources/Register.php    Test failed
10.    Execute Modification    ./Sources/Subs-Auth.php    Test successful
11.    Execute Modification    ./Themes/default/Register.template.php    Test successful

Has anyone encountered this problem and found a solution?

Offline TheDisturbedOne

  • SMF Hero
  • ******
  • Posts: 1,700
    • Disturbed Message Board
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #1 on: July 14, 2009, 10:34:51 PM »
Have you tried manually updating those files by parsing the upgrade on the upgrade site?

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline JimM

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,980
  • Gender: Male
    • Southern Spirit Hunters
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #3 on: July 14, 2009, 11:06:21 PM »
I had the same thing.

Each file had the exact same problem.  The installer is looking for this:

Code: [Select]
* Copyright 2006-2007 by:     Simple Machines LLC (http://www.simplemachines.org) *

and those files in my install had this:

Code: [Select]
* Copyright 2006:             Simple Machines LLC (http://www.simplemachines.org) *

I edited that line and it installed fine.
Jim "JimM" Moore
Former Support Specialist

Please do not PM me for support!                   
Installing SMF
Upgrade SMF
Manual Installation of Mods

Offline william777

  • Semi-Newbie
  • *
  • Posts: 64
  • Gender: Male
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #4 on: July 15, 2009, 07:50:09 AM »
I never had any problems upgrading SMF from the beginning to the current 1.1.9 version. However, I had the same 4 files "Test failed" as in forefront's case when trying to upgrade to 1.1.10.

[n3rve], do I just go ahead and press the "Install Now" button and then manually edit the 4 files and nothing else?

Offline Norv

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 18,313
  • Blue Wolf
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #5 on: July 15, 2009, 07:57:58 AM »
Please edit them as explained above by JimM, before installing. Then try again to apply the patch.
To-do lists are for deferral. The more things you write down the later they're done… until you have 100s of lists of things you don't do.
File a security report | Developers' Blog | Bug Tracker

Also known as Norv on D* | Norv N. on G+ | Norv on Github

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #6 on: July 15, 2009, 07:59:43 AM »
[n3rve], do I just go ahead and press the "Install Now" button and then manually edit the 4 files and nothing else?

See: SMF 1.1.10 Upgrade: Test Failed error when upgrading

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,614
    • StoryBB/StoryBB on GitHub
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #7 on: July 15, 2009, 08:21:21 AM »
Thanks for the advice, hugely useful!

I found that if the forum was 1.1.6 or earlier, upgrading it through to 1.1.9 then applying this, it would fail. But for a forum that was 1.1.7 when first installed, subsequently upgraded to 1.1.9, this applied fine.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Paracelsus

  • Sr. Member
  • ****
  • Posts: 876
  • Gender: Male
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #8 on: July 15, 2009, 06:12:31 PM »
I was also going to complain because I got those errors too, but then I saw this topic, replaced that copyright line in those files reapplied patch and flawless once more, great! ;D

Offline forefront

  • Newbie
  • *
  • Posts: 9
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #9 on: July 15, 2009, 10:12:59 PM »
I cannot thank all of you enough! Another flawless and perfect update.

Offline nc3man

  • Jr. Member
  • **
  • Posts: 111
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #10 on: July 16, 2009, 12:52:22 AM »
I am presuming if we wait the upgrade package will be fixed? I have upgraded at every juncture since installing smf, flawlessly each time, until the 1.1.9 to 1.1.10 attempt. I prefer to avoid manual edits, etc., unless absolutely required. Please advise...

Offline Paracelsus

  • Sr. Member
  • ****
  • Posts: 876
  • Gender: Male
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #11 on: July 16, 2009, 02:53:35 AM »
@ nc3man,

As it was said, you just have to do the edit quoted below in those 4 files and then reapply patch and it will no longer say "Failed" going instead smoothly as usual.

I had the same thing.

Each file had the exact same problem.  The installer is looking for this:

Code: [Select]
* Copyright 2006-2007 by:     Simple Machines LLC (http://www.simplemachines.org) *

and those files in my install had this:

Code: [Select]
* Copyright 2006:             Simple Machines LLC (http://www.simplemachines.org) *

I edited that line and it installed fine.

Offline Norv

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 18,313
  • Blue Wolf
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #12 on: July 16, 2009, 04:24:48 AM »
I am presuming if we wait the upgrade package will be fixed? I have upgraded at every juncture since installing smf, flawlessly each time, until the 1.1.9 to 1.1.10 attempt. I prefer to avoid manual edits, etc., unless absolutely required. Please advise...

The packages will be regenerated as far as I know, yes.
To-do lists are for deferral. The more things you write down the later they're done… until you have 100s of lists of things you don't do.
File a security report | Developers' Blog | Bug Tracker

Also known as Norv on D* | Norv N. on G+ | Norv on Github

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #13 on: July 16, 2009, 04:27:05 AM »
The packages should have been regenerated by now.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline -Scott

  • Jr. Member
  • **
  • Posts: 172
  • Gender: Male
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #14 on: July 16, 2009, 07:36:47 AM »
I am still getting the upgrade errors this morning.



-Scott

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #15 on: July 16, 2009, 07:44:30 AM »
I've raised concerns regarding this error in the staff boards. We hope to have it resolved as soon as possible.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Re: Upgrade from 1.1.9 to 1.1.10 failed
« Reply #16 on: July 16, 2009, 04:56:36 PM »
Ok, confirmed. Package Regenerated and can be downloaded here.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan