• Welcome to Simple Machines Community Forum. Please login or sign up.
January 23, 2022, 02:23:16 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


PrettyURL Mod - white screen

Started by dlugasny, May 28, 2009, 10:23:48 AM

Previous topic - Next topic

dlugasny

hi everyone,

      maybe somebody knows what can be a reason of white screen after rewriting an URL by PrettyURL MOD ?

After starting this script I cant reach start page. Firefox showing me only white page.


I have tried to disable this in .htaccess file but without result.



Do You know any others good Mods for 1.1.9 which I can use to rewriting URL`s ?



cheers

Dannii

http://code.google.com/p/prettyurls/wiki/TroubleShooting Follow the first section to disable the mod. Then check your SMF and Apache error logs.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

dlugasny

Thanks a lot for help :)


I will check this.  8)

dlugasny

Quote from: Dannii on May 28, 2009, 10:31:21 AM
http://code.google.com/p/prettyurls/wiki/TroubleShooting [nofollow] Follow the first section to disable the mod. Then check your SMF and Apache error logs.

It doesnt work but...


I have found this in configuration of prettyurl

QuoteFirst check your server supports .htaccess per-directory config files and mod_rewrite

Does anybody knows how can I configure this in Debian Etch 4.0 ?

I have tried to find an answer in the google but without result...





In my configuration everything is working 100% (mod_rewrite also script prettyurl is installed correctly) but I`m not sure about configuraion of .htaccess per-directory...


help...





Dannii

You need to set the AllowOverride setting.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

dlugasny

Quote from: Dannii on May 28, 2009, 09:17:46 PM
You need to set the AllowOverride setting.


Would You be so kind and post this settings ? I have tried everything what I know but without result...  :(

Dannii

It's just an apache setting. It might be commented out and you have to remove the #, or you'll have to add it to the right section. There should be lots of Debian tutorials...
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

dlugasny

Does anybody knows how to setup this Allowoverride option ?


Maybe somebody which have installed PrettyUrl (working ) can paste here to the post his settings of httpd.conf and .htaccess ?


Everything is rewriting except first page... I dont know why ... what should I do ?

I have still white screen and no informations in the logs...



I have installed mod_rewrite and mod_userdir ... everything is running correctly with phpbb and other forums except smf... ehhhh


...help...

Dannii

http://drupal.org/node/43783#comment-263393
Try something like that, though it may not be exactly the same.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

dlugasny

Quote from: Dannii on June 03, 2009, 09:50:25 PM
http://drupal.org/node/43783#comment-263393 [nofollow]
Try something like that, though it may not be exactly the same.

still doesnt work... I think this script generating .htaccess which making loops in the rewriting process.

On my server it doesnt work. I dont want to spend more time to fight with this. Would be great to have nice URL rewriting for SMF.

I have tested the speed of google indexing with phpbb and smf.


PHPBB with url rewriting mode and sitemap was ready to search in the google after 13 hours (after second visit of googlebot)


SMF with standard SEO Friendly URL ... 7 days... no comment... (after 19 visits) I think this is the power of prettyurls if its working correctly ofcourse.

Test was prepared with two diffrent subdomains     subdomain.mydomain.com [nofollow]

                                                                             subdomain2.mydomain.com [nofollow]

This mod is realy important for smf.


Here is content from /etc/apache2/sites-available/default



<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>




Maybe one day if will be ready I will try to back to smf.


Thanks for nice support.



Dannii

You may also need a RewriteBase / line too.

If you are running your own webserver you should know how to manage it yourself. I do try to help everyone, but there are an infinite ways a server could be set up, and so if you run into trouble you need to ask your host. If you host your own server that means fixing your own problems. Sorry I can't help much more.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

dlugasny

Quote from: Dannii on June 06, 2009, 05:07:50 AM
You may also need a RewriteBase / line too.

If you are running your own webserver you should know how to manage it yourself. I do try to help everyone, but there are an infinite ways a server could be set up, and so if you run into trouble you need to ask your host. If you host your own server that means fixing your own problems. Sorry I can't help much more.


I guess that without the RewriteCond, index.php page is stuck in the rewrite process and loops. 

Do You know how to correct this ?

Dannii

What URL are you trying to access? Do you know what it is trying to redirect to?
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Daniel15

Quote from: dlugasny on June 05, 2009, 03:41:07 PM

Here is content from /etc/apache2/sites-available/default



<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>


You also need "AllowOverride All" in the <Directory /> section. Also, be sure to force-reload Apache (/etc/init.d/apache2 force-reload) for it to take affect.

If still having problems, please type

tail /var/log/apache2/error.log

And paste here the result.
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

dlugasny

Hi

I have exacly the same settings like in Your post


<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>



I have installed completly new forum with PrettyUrl mod. Then I`m selecting option to

Rewrite Boards name

Rewrite Topics

Rewrite Actions


I`m saving this. Lets check how its working ...


www.mydomain.com/forum/             - works ok

I`m selecting one board


www.mydomain.com/forum/new-board/    - works ok


I`m selecting post in the forum (to read)

www.mydomain.com/forum/new-board/my-first-post/  - works ok



Then I`m trying to reply for post or create new one . I`m clicking on the button Reply / or Create new post

I see website "Post Reply". I`m writing new post blabla...

Post is ready to publish so lets post it...


I`m pressing button Post ...   and then I dont have an access to forum at all... WHITE SCREEN   NO ACCESS TO FORUM / NO ACCESS TO POSTs / NOTHING


LOGS:

tail -f /var/log/apache2/error.log    -  no errors - log is empty



tail -f /var/log/apache2/access.log    -


72.xx.xx.xx - - [06/Jun/2009:15:45:47 +0200] "GET /forum/apfel-forum/ HTTP/1.1" 200 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.2; pl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10"


My .htaccess


#       Pretty URLs mod
#       http://code.google.com/p/prettyurls/
#       .htaccess file generated automatically on: June 4, 2009, 16:42

RewriteEngine on


#       Rules for: actions
RewriteRule ^(activate|admin|announce|ban|boardrecount|buddy|calendar|cleanperms)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(collapse|convertentities|convertutf8|coppa|deletemsg|detailedversion|display|dlattach)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(dumpdb|editpoll|editpoll2|featuresettings|featuresettings2|findmember|help|helpadmin)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(im|jsoption|jsmodify|lock|lockVoting|login|login2|logout)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(maintain|manageattachments|manageboards|managecalendar|managesearch|markasread|membergroups|mergetopics)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(mlist|modifycat|modifykarma|modlog|movetopic|movetopic2|news|notify)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(notifyboard|optimizetables|packageget|packages|permissions|pgdownload|pm|post)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(post2|postsettings|printpage|profile|profile2|quotefast|quickmod|quickmod2)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(recent|regcenter|register|register2|reminder|removetopic2|removeoldtopics2|removepoll)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(repairboards|reporttm|reports|requestmembers|search|search2|sendtopic|serversettings)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(serversettings2|smileys|smstats|spellcheck|splittopics|stats|sticky|theme)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(trackip|about:mozilla|about:unknown|unread|unreadreplies|viewErrorLog|viewmembers|viewprofile)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(verificationcode|vote|viewquery|who|\.xml)/?$ ./index.php?pretty;action=$1 [L,QSA]

#       Rules for: boards
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/?$ ./index.php?pretty;board=$1.0 [L,QSA]
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([0-9]*)/?$ ./index.php?pretty;board=$1.$2 [L,QSA]

#       Rules for: topics
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([-_!~*'()$a-zA-Z0-9]+)/?$ ./index.php?pretty;board=$1;topic=$2.0 [L,QSA]
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([-_!~*'()$a-zA-Z0-9]+)/([0-9]*|msg[0-9]*|new)/?$ ./index.php?pretty;board=$1;topic=$2.$3 [L,QSA]




I have also tried with

RewriteBase /
RewriteBase /forum/apfel-forum

etc etc.....


Any ideas ?   Maybe the problem is with database ?
When I completly remove PrettyUrls using uninstall.php for PrettyUrl then  forum is working (ofcourse without SEF urls)


I dont understand this... at all... everything is running except this "nice" mod... 


Maybe somebody can help me now ?  :(

Dannii

When you submit a form, what address does it go to?
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Advertisement: