• Welcome to Simple Machines Community Forum. Please login or sign up.

Members wait for approve allways 0 [2.0 beta 4]

Started by feline, September 16, 2008, 04:04:11 PM

Previous topic - Next topic

feline

September 16, 2008, 04:04:11 PM Last Edit: September 28, 2008, 04:23:37 PM by SleePy
On the member management, the number of Awaiting Approval is allways 0.

See attach.

Fel

SleePy

It was like this in 1.1 as well. Awaiting activation and awaiting approval always shows if you have that set in registration.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

feline

I have set "Method of registration employed for new members" to Member Approval.

And at the top box is see:
There is one member awaiting approval.

Not enough ?

Fel

SleePy

Yes, but this is how it has always has been :) I have a feeling this was done on purpose.
On my 1.1 board I have "Awaiting Activation" showing up always for members who are awaiting activation, even if there are none.

Most likely I assume this was done so admins would know where to manually approve their members at :)
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

AurielStone

I think what feline is reporting is not that the Activation tab is always showing even if no one is waiting for approval, but rather that with people waiting for approval the Activation tab still shows 0 waiting and no registrations to approve. Even if you go up and click on the "There is one member awaiting approval." link, you are taken to an empty Approval tab. 

There seem to be quite a few people having this problem. I'm having it myself.

In the error log, I see this:

http://.../forum/index.php?action=admin;area=viewmembers;sa=browse;type=approve

8: Undefined index: totalMembers

File: /home/content/.../html/forum/Sources/ManageMembers.php
Line: 113

SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

AurielStone


Deprecated

I had independently discovered this bug myself, and had intended to post my observations sooner (probably discovered it about the same time). In any case I had already put my fix into a mod package, and tested it out and verified that the fix works, and that the totalMembers errors ceased.

So anybody who wants to patch their ManageMembers.php to stop the errors can download and install the mod package attached to this post. Or just find the one instance of totalMembers and change that to total_members by manual edit.


purper

Registration reply email and waiting for counter works now!  Tnx for the solution!

Regards,

Richard

snork13

Quote from: SleePy on September 24, 2008, 06:55:32 PM
Bug #2577: "Undefined index: totalMembers" when viewing members awaiting activation

So it will be fixed with the next release of smf

Until fixed you will not be able to appove the waiting members, as they never show up. You know how many, but upon clicking the link to appove you see no one. It is a simple fix though. I know I can look at is_activated in the database, and look for "3", but not everyone whould do this.

-snork13
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Deprecated

It's easier than that even. Just go to Search For Members (admin) and uncheck Activation Status "Activated." Hit "Search" and you get your list of unactivated members.

Or apply the fix above.

Or do the manual edit.

Or just let the new members self activate.

Or who needs new members anyway? ;)

snork13

Quote from: Deprecated on September 29, 2008, 03:46:43 PM
It's easier than that even. Just go to Search For Members (admin) and uncheck Activation Status "Activated." Hit "Search" and you get your list of unactivated members.

Or apply the fix above.

Or do the manual edit.

Or just let the new members self activate.

Or who needs new members anyway? ;)

I manually edited the file, and before searching mantis. I of coarse started in the database so I could find the key and searched the querys to find the context. I should have look for help here first..LOL IF there is a hard way I will find it. It did only take 10-15 mins that I will never get back...
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

Deprecated

LoL @ Snork :)

I bet both you and I find that sometimes the easiest way to change things is to just go directly to phpMyAdmin and just change the data at it's source. :)

Like when I forget one of my passwords. Who wants to go through the email "forgot password" procedure when you can just open phpMyAdmin and change it in about 30 seconds?

JCWohlschlag

Hey, Deprecated. I just wanted to thank you for providing such a quick and easy fix for this bug.

Now to fix the 72 members that have not activated on our site! :P

Deprecated

Hi JCW and I'm glad I could help you. While I did independently isolate the bug and create the fix, I was not the first to post on the topic and I should have been.

When you are up to your ass in alligators it's hard to remember your original objective was to drain the swamp.

jacmoe


Deprecated

Aw shucks, ma'am, I'm just doing what I can to protect the West! ;)

* Deprecated gets back on his horse and rides off into the sunset... ;)

Sudhakar Arjunan

Working on New Mods & Themes for SMF... Will update soon... My Blog page
My Smf forum : Discuss ITAcumens :: My SMF Forum

ethankcvds

@Deprecated your fix is not working for me at all :(.
No Pm's for support please!

Advertisement: