• Welcome to Simple Machines Community Forum. Please login or sign up.

Beta 4 (new) bugs...

Started by enetec, September 08, 2008, 05:51:55 PM

Previous topic - Next topic

enetec

September 08, 2008, 05:51:55 PM Last Edit: September 09, 2008, 02:00:59 PM by SleePy
I've just installed the new 2.0 beta 4 over my 2.0 beta 3.1 installation. No MODs/add-ons installed.

I've found some bugs/troubles:

1) Polls aren't no more correctly tiled...  :o

2) Using IE 6.x, topics "randomly" are showed with all "message parts" all lower the "user part": left side (user details) with no message at right, then, at bottom, (no user details) and at right the message body.

This issue "come & go", some topic yes, some no, some refreshes fix it, some others make it out.

Tested by more than user on at least two forums on different servers/os/maintainers ...  ???

3) Navigation links are no more "color customizable" aside of other links... this is a BAD thing with some backgrounds colors/personalizations...
(EDIT: settings moved from Themes/default/style.css to Themes/default/css/index.css  ::))

4) Want more?  :P

Seriously, points 1) & 2) are really BAD bugs IMHO...  :o

karlbenson

What browser are each of them specific to, IE6?

enetec

September 08, 2008, 11:03:52 PM #2 Last Edit: September 08, 2008, 11:29:37 PM by enetec
Quote from: karlbenson on September 08, 2008, 06:18:49 PM
What browser are each of them specific to, IE6?

Points # 1) & 3) are common to ALL browsers...  :'(

About bug # 2) I've some news...

Bug seems to come out especially when one or more messages are a bit larger than usual and "go away" if you enlarge enough the IE 6.x window (with "enough" which could be even "only a bit"!).

Best is, that, if then you re-size the window to the original size (or even smaller...) posts still remain well viewed!!!  :o

So, it seems a bug of IE 6.x related to <DIV> tags BUT since a lot of users still use IE 6.x (and problems of IE 6 with DIVs are well known...  ::)) I think a fix using "double tags" (<table>s AND <div>s) or "specific tags" for IE 6.x in code is absolutely needed!!!  :-[

enetec

September 08, 2008, 11:27:27 PM #3 Last Edit: September 09, 2008, 12:44:11 AM by enetec
Want more?  :-\

4) With standard SMF theme, last post of every page lacks of the "separation <hr>" (grey horizontal line) from the previous (upper) post...  :(

EDIT: probably my fault. Fixed.  :-X

metallica48423

make sure you do a hard refresh and clear your browser cache.  it sounds almost like things are getting mixed up

there were a lot of template changes in this release, so its possible you're getting cache stuff mixed up
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

enetec

Quote from: metallica48423 on September 09, 2008, 12:01:41 AM
make sure you do a hard refresh and clear your browser cache.  it sounds almost like things are getting mixed up

there were a lot of template changes in this release, so its possible you're getting cache stuff mixed up

It's the first thing I've tried... (I'm a newbie, NOT a rookie...  ::))

BUT, as I've written in first post:

- 2 different forums, maintained on different machines by different people (with same problems)

- A LOT of different users "testing" the reported bugs all with the same results...

- I've used even "fresh" machines never used on those forums to test better (and be sure before posting here...)

Yes, there has been a LOT of template change in this release... and SOME new "visual bugs"...  ::)

enetec

September 09, 2008, 12:22:25 AM #6 Last Edit: September 09, 2008, 12:44:49 AM by enetec
4) "Navigated" tabs surrounding posts (reply, print, etc...) take a different color from "unvisited" ones... it happens ONLY on those TABS and NOT on "forum navigation tabs".  :(

(SMF default theme - IE 6.x)

MultiformeIngegno

Yes, I can reproduce those errors in my installation!!! :O
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

MultiformeIngegno

RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

enetec

Quote from: lorenzone92 on September 09, 2008, 06:47:53 AM
Look here [nofollow]! :'(

Yes...

Bug #1)
[nofollow]

Bug #2) (left OK, right "not OK)
[nofollow]

Bug #4) (bad color on "visited" link...)
It happens only with IE 6.x (not with IE 7.x)  ::)

enetec

Quote from: enetec on September 08, 2008, 11:27:27 PM
Want more?  :-\

4bis) With standard SMF theme, last post of every page lacks of the "separation <hr>" (grey horizontal line) from the previous (upper) post...  :(

EDIT: probably my fault. Fixed.  :-X 
It comes & go... with ALL browsers.  ??? :-\

MultiformeIngegno

Someone who can confirm this really BAD bugs...?
Or maybe post some fixes... O:)
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

SleePy

Ok, I can get the polls issue
Bug #2506: Polls are miss aligned

The Right to Left issues are known.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

enetec

Quote from: SleePy on September 09, 2008, 02:00:23 PM
Ok, I can get the polls issue
Bug #2506: Polls are miss aligned
I've done a "temporary" patch for this but I prefer to post eventually a definitive solution...

Quote
The Right to Left issues are known.
???

Anyway...
Quote from: enetec on September 08, 2008, 05:51:55 PM
2) Using IE 6.x, topics "randomly" are showed with all "message parts" all lower the "user part": left side (user details) with no message at right, then, at bottom, (no user details) and at right the message body.

This issue "come & go", some topic yes, some no, some refreshes fix it, some others make it out.
I've done a fix for this:

EDIT the file <yourforumfolder>/Themes/default/css/ie6.css
(for default theme...)

and add at the end:

#forumposts .postarea
{
margin-left: 1%;
float: right;
}


This fix layout bugs of IE 6.x with your css setup...

Please note that if you install this modify in forum.css you will have the same "bugged" layout on all Firefox browsers (fixed, not intermittent as on IE 6.x...)  :(
So apply it *only* on ie6.css file!

About the line between last post & previous one "coming & going", I've to study it a bit more...  :-\

MultiformeIngegno

@enetec: thanks for that fix! ;)
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

enetec

The solution above could be applied to this open issue: ID0002471 IE6 Topic Issues  ::)

MultiformeIngegno

RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

metallica48423

lorenzone: please be patient.  the issue was reported and the developers are aware of it, but it has't yet been patched.

Please remember that SMF 2.0 is beta software and will have bugs, especially considering the level of changes that have been made to the templates.

Thanks.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

MultiformeIngegno

September 13, 2008, 02:11:20 PM #18 Last Edit: September 14, 2008, 03:53:24 PM by lorenzone92
Quote from: metallica48423 on September 13, 2008, 09:45:31 AM
Please remember that SMF 2.0 is beta software and will have bugs, especially considering the level of changes that have been made to the templates.

Thanks.
This is not an explanation. If you release something you have to be sure that works properly!!
These are really BAD bugs...  I would have released an hot fix...
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

enetec

Quote from: enetec on September 09, 2008, 09:29:57 AM
Quote from: enetec on September 08, 2008, 11:27:27 PM
Want more?  :-\

4bis) With standard SMF theme, last post of every page lacks of the "separation <hr>" (grey horizontal line) from the previous (upper) post...  :(

EDIT: probably my fault. Fixed.  :-X 
It comes & go... with ALL browsers.  ??? :-\

This bug I reported is now indicated in this issue:
http://dev.simplemachines.org/mantis/view.php?id=2586  ;)

Advertisement: