Advertisement:

Author Topic: [retitled] Database *IS* screwed up  (Read 2158 times)

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
[retitled] Database *IS* screwed up
« on: August 26, 2008, 03:21:12 PM »
[Edit: I've removed the earlier comments which don't seem to add to describing the problem]

smf 1.1.5, no mods, fresh install, big database from previous backups



ETA: The comment below is from a colleague passively investigating the same problem:
Quote
While browsing through the myphp I found this:

Select_full_join     2,101

The number of joins that do not use indexes. If this value is not 0, you
should carefully check the indexes of your tables.


I have no idea what it means, but the value is not 0 and the 2,101 is in
red.  there are a couple of other items on that page in red too.

Is this significant?

I'm coming up with additional information but we don't want to bump the thread, eh? :)

The forum was upgraded from pre-1.1.5 and evidently had many mods installed although none are installed yet on this fresh 1.1.5 install. Here is the list.

Quote
1.     cbi, 1.0      1.0
2.    Show Google PageRank    1.0
3.    SMF 1.0.6 Update    1.0
4.    Simple ImageShack    1.0.4
5.    Karma Description Mod    2.2
6.    SMF 1.1.2 Update Package    1.1.2
7.    Ignore user    1.3
8.    RSS Feed Icon    1.1
9.    SMF Links    1.1
10.    VisualWarning    1.32
11.    Integrated Chat    2.6
12.    PJIRC Integrated Chat Mod    2.0
13.    MessagePreviewOnHover    1.0
14.    Quick Upload    2.1
15.    Streaming 4.2.1b    4.2.1b
16.    Ignore user    1.2
17.    Password Protect Boards    0.1
18.    Enhanced Quick Reply    TBA
19.    Ad Managment    1.4.1
20.    Googlebot & Spiders Mod    1.0.5
21.    Board Viewers    0.6
22.    Profile Music    1.0
23.    SMF 1.0.7 / 1.1 RC2 Update    1.0
24.    vWarn Mod    1.10
25.    YouTube BBC Tag (XHTML Compliant)    1.0
26.    SMF 1.0.11 / 1.1.3 Update    1.1
27.    Monthly Statistics on Profile    1.0
28.    Award Mod    1.1
29.    Contact Page    1.0
30.    ShowTopics    1.1
31.    SMF Staff Page    1.5.1
32.    Reason For Editing Mod    1.12
33.    GoogleVideo BBCode by Yakuza    0.1
34.    YouTube BBCode by Yakuza    0.2
35.    CAPTCHA (code verification)    0.1
36.    SMFShop    2.2
37.    Member Awards    1.0.1
38.    SMF Gallery Lite    1.6.2
39.    Paid Subscriptions    0.10
40.    SMF Trader System    1.0
41.    Simple Blog    1.2
42.    Simple Blog    1.2
43.    AutoSig    1.1
44.    Board Viewers Mod    1.0
45.    Simple ImageShack    2.0.1
46.    SMF Links    1.4
47.    SMF Radio    0.4
48.    audiblepm 1    1.0
49.    Simple Blog    1.3
50.    Youtube Field by Alan S    1.0
51.    Country Flags    1.0.1
52.    Signature Option Post    1.0
53.    Shop Item: Profile Image    0.1
54.    K-Detection    1.1
55.    Spam Me Not Mod    1.01
56.    Profile Comments    1.2.1
57.    Edit Meta Data    1.0
58.    SMF Arcade    2.0.7
59.    Ignore user    1.2
60.    Link Thumbnail    1.0
61.    Digg Topic    1.0
62.    Member Notepad    1.0
63.    SMF 1.1.2 Update Package    1.1.2
64.    Ad Managment    2.3
65.    Display Age and Location next to posts    1.0
66.    Enhanced Quick Reply    TBA
67.    Location Mod    1.2
68.    SMF Staff Page    1.5.1
69.    Enhanced Calendar    1.1
70.    Streaming 3    4.2.2b
71.    Akismet Spam Blocking    1.1.1
72.    Topic description    1.1
73.    Color Bar    2.0
74.    Registered Links    1.0
75.    GoogleTagged    1.0
76.    MySpace Field    2.4
77.    FontandSizeDropdown1.1    1.1
78.    Visual Verification Options    0.1
79.    Users Online Today Mod    1.4.0
80.    Googlebot & Spiders Mod    2.0.3
81.    User Control Panel By Alan S    1.1
82.    SMF 1.0.12 / 1.1.4 / 2.0 b1.1 Update    1.0
83.    Auto Embed Video Clips    1.3
84.    Add Domaintools to TrackIP    1.0
85.    Highlight Search Keywords    1.1
86.    Moderator Activity Report for SMF1.1.4    1.2
87.    Neat Board Layout    1.0
88.    SMFShop    3.0
89.    Allowed Groups Embedded Flash    1.2.3
90.    SMF Sitemap    1.2.1
91.    SMF 1.0.13 / 1.1.5 / 2.0 b3.1 Update    1.0
92.    SMF 1.0.13 / 1.1.5 / 2.0 b3.1 Update    1.0
93.    SMF 1.0.13 / 1.1.5 / 2.0 b3.1 Update    1.0

I'm wondering if one of them could have changed the database in a way making it impossible to access it without causing errors.

I'll be adding more information shortly on the symptom that we're trying to fix.
Okay here's some more info. I've tried to make a test post. I have my profile set to return to the topic after posting. This is what it looks like after I hit 'post.'



The post does not show at the beginning of the board index. Here's some strange stuff on the last page of the forum index:



(right click and view image to get a better resolution of the shots)
I've been digging on this for 3 hours now.... :(

Here's some stuff from the error log:

multiple times:

1024: sendNotifications(): non-existant topic passed File: ./Sources/Subs-Post.php Line: 1391

one user is getting loads of stuff like this:

8: Undefined index: ajax_in_progress Datei: ./Themes/default/BoardIndex.template.php (main_below sub template - eval?) Zeile: 453
8: Undefined index: most_online_ever Datei: ../Themes/default/BoardIndex.template.php (main sub template - eval?) Zeile: 398
8: Undefined index: pm_short Datei: ./Themes/default/BoardIndex.template.php (main_above sub template - eval?) Zeile: 557
8: Undefined index: ajax_in_progress Datei: ./Themes/default/MessageIndex.template.php (main_below sub template - eval?) Zeile: 453
8: Undefined index: pm_short Datei: ./Themes/default/MessageIndex.template.php (main_above sub template - eval?) Zeile: 557
(similar errors same guy for 3 pages worth)

Datei and zeile are of course German for file and line. How the heck is German getting in there? How can the same code say "line" one time and "zeile" the next? I would think that the code that displays the errors is the same code all the time, and the words "line" and "zeile" are not stored in the database, or at least that's what I would expect.[/hr][/hr][/hr]
« Last Edit: August 28, 2008, 01:53:52 PM by Deprecated »

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
What character set is the database on? ISO or UTF8?

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
The forum owner says he is not using UTF-8 so I presume that means he is using the default.

What is really bizarre is that German datei/zeile stuff. The owner claims he has a fresh install with no mods, and a site visit seems to support that. The theme appears to be SMF default and that's what it is set for.

BTW I realize it would be helpful to have a direct look, so here's the URL and a test account login:

URL: http://www.peta-sucks.com/smf
user: SMFer
pass: thankyou

Interesting site... ;) Actually I might want to join as a member when this problem is resolved. They've got a fairly active site with almost 1,000 members and even at this moment about 60 online even though the forum is usable only for reading posts.

I'm fairly sure this is a database problem and I'm basing that on the owner's assurance that the installation has all fresh files and no mods installed. The mods installed list shows there are no mods installed, but of course that is not a completely reliable indication.

Note that I have what appears to be an almost-admin account, so I can access most of the admin functionality if there are any questions about what is this setting or suggestions that I should try this or that. Let me know if there's anything I should look at or try.

ETA:

I've freshened all the 1.1.5 required files in $themedir, $languagedir, $sourcedir, and I've also replaced $boarddir index.php and SSI.php. You may find it interesting that I do not have FTP access so I wrote impromptu mod packages to install the files, took about 5 minutes each. :)

Still no improvement. I feel even more certain that this is a database problem.
« Last Edit: August 27, 2008, 10:24:00 AM by Deprecated »

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,907
  • Gender: Male
    • N3RVE.COM
Re: [retitled] Database seems to be screwed up...
« Reply #3 on: August 27, 2008, 11:39:49 AM »
Hmm . . . I worked on that forum (http://peta-sucks.com/smf) few days ago and refreshed it by replacing all files.
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: [retitled] Database seems to be screwed up...
« Reply #4 on: August 27, 2008, 11:41:21 AM »
This seems to be a major hosting problem if replacing all the SMF files do nothing.

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: [retitled] Database *IS* screwed up
« Reply #5 on: August 28, 2008, 01:55:07 PM »
Well the database was borked. I fixed it. End of story. :)

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: [retitled] Database *IS* screwed up
« Reply #6 on: October 17, 2008, 04:22:15 PM »
I'm adding this cross link just in case anybody else has a similar problem:

http://www.simplemachines.org/community/index.php?topic=261462.msg1703888.0