• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 10:44:16 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Duplicate Error in the Topic Notifications ... help please?

Started by mymktp1, May 13, 2008, 01:28:27 AM

Previous topic - Next topic

mymktp1

Converting posts (this may take some time)... Successful.
Converting polls... Successful.
Converting poll options... Successful.
Converting poll votes... Successful.
Converting personal messages (step 1)... Successful.
Converting personal messages (step 2)... Successful.
Converting topic notifications... Unsuccessful!
This query:
INSERT INTO `kitping_smf`.smf_log_notify
(ID_MEMBER, ID_TOPIC)
VALUES ('160', '111'),
('223', '149'),
('223', '147'),
('223', '190'),
('223', '113'),
('247', '105'),
('289', '83'),

.....
.....
....


Caused the error:

Duplicate entry '961-1063-0' for key 1

What Does this mean ???? Can someone please help me I would greatly appreciate it :D

SleePy

Welcome to SMF

Are you using the .sql and convert.php linked in the stickies for your version of phpBB at the top of this board?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Oh hey... didn't realize that I needed to use this one oopz... it's all working now... however... I'm having a problem with the Characters... My forum in phpbb was all in THAI and for some reason it's not outputing correctly.. I already set it to UTF-8 when using the convert.php... I'm not really sure why this is happening???

SleePy

Do you have the -UTF8 versions of the language files?
Do they show up correctly in the database?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Hey, thank you so much for your help

... but I just really messed up... I was trying to change the collation type in phpbb2 (to see if that was the problem because it was all set to latin1... ) so I exported my entire database...and corrected all the latin1's to UTF-8  and then deleted the database on myserver... now I can't import the database...back on my server...I do still have the database file saved on my computer and was hoping someone could give me some advise???  I don't really know what I'm doing so I'm kind of stuck right now...


*** Back to your answer... I install SMF... Installed the Thai language Packages... and everthing seemed to display okay (tried posting new stuff in THAI and it worked) ... then I tried converting my phpBBforum to the SMF and it succeeded but all the font is weird... I was assuming that it might be because my phpBB2 SQL database had all of it's collation set to Latin1 so I tried what I stated above... and I'm kind screwed right now.... any suggestions???

sorry for the double post earlier

SleePy

Why won't the database import?
Do you get an error?

SMF does have a convert htmlentities to UTF-8 option in its forum maintenance which might fix it if its because they are being stored as htmlentities.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Hi, and whew... I got my phpbb data base back and restored...and the collation is now utf8...

However... I tried using the converter again setting it to utf 8 ...and nothing happened... still having problems with the fonts and I've also tried what you suggested with the "Convert HTML-entities to UTF-8 characters" <---- it seemed to be doing something but nothing happened either... any suggestions ???

mymktp1

I've also tried

1. install smf without setting it to utf-8
2. then using utf-8 converter phpbb2
3.  andthen changing the forum to utf-8

this didn't work either...

.... kind of confused of why this is happening even thought phpbb sqldatabase has been set to utf8 entirely...

SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf


SleePy

Ok,

Looking at this topic:
http://timsradio.net/smf/index.php?topic=237.0
I see that the html isn't being parsed correctly.
Is the other words such as the last 2 posts correct?

HTML not being translated to SMF is a different problem than getting the characters to convert right.

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Hi, there.... Thank you for your help... I finally solved it....

kind of hard to explain

the problem was the characters that were being stored in my phpBB database were all in Latin1 even though I changed the collation to utf8  they were previously stored in Latin1 Characters which made them display incorrectly since the SMF converter directly reads what ever character is stored in the phpBB database.... what I had to do was EXPORT my database from the phpBB ADMIN Forum ... which exported my characters exactly in Thai Font/Characters  .... after that I dumped the entire phpBB forum  database and restored it with the new one with the correct Thai Characters....(that way the characters are now stored in Thai instead of the squiggly characters in Latin1) ... after that converting it to SMF was no problem~!

... it's quite simple but confusing to explain I guess... but it's all working fine now YEY~!

Responding to your reply...

some of my posts in phpBB forum had html tags in them which for some reason didn't convert out correctly...which probably has something to deal with the way it was stored on the phpBB database... but ... I guess I can live with that ... or fix the posts manually which is going to take some time... if you have any suggestions that would be cool :P but anyhows... thanks for the HELP~!

SleePy

Do you know how they are being stored in the database?
Are the html tags like < or are they being stored with with htmlentities like: &alt;?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1


SleePy

Well I could have those converted into their proper HTML formats. But that would mean only admins could edit the post as anyone else who does would revert it back to the way it was before the conversion.
Do you want to try that?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Yeah I could try that... so what information to I need to give ya? .

SleePy

Give this one a try for phpBB2.
I assumed you where using phpBB2, but if your not let me know which converter you are using and it can be tweaked.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

mymktp1

Hey, there

yes, I am using phpBB2 ... and it practically almost worked....

it corrected all of the <  and  > signs however.... it didn't change the &quot; to " actual quotes  could you help me with that too after that all should be good :)

mymktp1

Hey I just fixed it my self lolz... everything is working perfectly now ... thank you so much for your help~!  I really appreciate it :D Thanx again~!

SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Advertisement: