• Welcome to Simple Machines Community Forum. Please login or sign up.
January 28, 2022, 01:17:27 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Integrate Lightbox

Started by quake101, April 10, 2008, 11:03:44 PM

Previous topic - Next topic

quake101

April 10, 2008, 11:03:44 PM Last Edit: May 29, 2008, 02:13:19 PM by quake101

Compatibility
For SMF 1.1.x and SMF 2.0 Beta 3 Public

Introduction
Integrates Slimbox into SMF.
Slimbox is a 7kb visual clone of the popular Lightbox JS v2.0 by Lokesh Dhakar, written using the ultra compact mootools framework. It was designed to be small, efficient, more convenient and 100% compatible with the original Lightbox v2.

This modification is Licensed under the Creative Commons Attribution 2.5 License - http://creativecommons.org/licenses/by/2.5/

Features
o Integrates Slimbox to work with
- Attachments
- Non-Linked Images
- Text-based Links to images
o Prevents Slimbox from affecting images linked to page/urls
o Fixes Imageshack.us & Photobucket links to work with Slimbox

Installation
Simply install the package to install on the SMF Default Core Theme ONLY.
All other themes will require manual edits for index.template.php and display.template.php

Note, due to differences in themes, you may have to slightly modify the 'default' edits to work on other themes. (eg if you get template parse error, check whether there is an extra unneeded php echo ' at the beginning of the edit or '; at the end.

Donate
Has this modification helped you? Support the developer by Donating

Support
Please use the modification thread for support with this modification.
(Please don't ask me to do the edits for you)

Changelog
1.0 - 24th November 2007
o Initial Release
1.1 - 8th December 2007
o Fixed uninstall file error (Thanks AllMassive)
1.2 - 13th December 2007
o Disabled Lightbox2 for signature images and Smilies
o Fixed Imageshack images to work with Lightbox2
o Disabled for stats page, due to conflict/error
1.3 - 25th December 2007
o Fixed haystack/needle bug
o Made 2.0 beta 1 compatible
o Fixed smilie url escaping
1.4 - 17th January 2008
o Re-wrote everything added to subs.php
o Fixed Imageshack links
o Added Photobucket non-direct links fix
1.5 - 13th April 2008
o Replaced Prototype Framework with Mootools Framwork
o Replaced Lightbox2 with Slimbox
o Made 2.0 Beta 3 Public compatible
1.6 - 29th May 2008
o Fixed text-based links to images
o Fixed "Undefined index: host"
o Added support for smfgarage mod
o Made images open in an image set

SgtMic

April 10, 2008, 11:04:45 PM #1 Last Edit: April 10, 2008, 11:08:35 PM by SgtMic
When will a release for Beta 2.1 or beta 3 be ready?  :D
There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)

quake101

Quote from: SgtMic on April 10, 2008, 11:04:45 PM
When will a release for Beta 2.1 or beta 3 be ready?  :D

SgtMic,

I just took over this mod from karlbenson and I'm currently working on the next release.  The next release will include SMF 2.0 Beta 3 Public support. I do believe the mod currently supports Beta 2.1 but I do not have a copy of Beta 2.1 to test with. I hope to have the next release out within a few days. :)

SgtMic

Cool beans. It's a great feature for SMF.
There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)

Apllicmz




klra

Ok, I installed the mod, and it works great on hotlinked images.

But not attached images.

What can I do to have it work with them? (ver 1.1.4 )

quake101

Quote from: klra on April 13, 2008, 12:59:11 AM
Ok, I installed the mod, and it works great on hotlinked images.

But not attached images.

What can I do to have it work with them? (ver 1.1.4 )
The mod should be working with attached images also. Please post or pm the url to your board and I'll look into it. :)

quake101

Version 1.5 has been released.

[кѕ]ваηε-σ

ok I added this to a fresh install of 1.1.4 on my localhost using xampp

this is the only mod. first i tried version 1.5 and then i uninstalled that and installed version 1.4


How in the world do i get this mod to display images using slimbox? I tried everything and still can't get the stupid images do be displayed with in slimbox or lightbox.

Click my sig, I dare you. (you might enjoy it)


I have 1337 M0DЄЯΑŦ0Я ѕκιŁŁѕ.


Quote from: ваηε-σ, #lëñņðN`, мµŋτς[02:42] [кѕ]ваηε-σ: I just pwned microsoft and completely ghosted one hard drive onto another. Two computers with the exact same operating system, exact same everything.
[02:42] ⌠Ķζ⌡мµŋτς ©  / DarkForce: lmfao, XD
[02:43] *[Ҝﮘ] #lëñņðN` ¨εﮘ`: hahahaha, noice

quake101

Quote from: [кѕ]ваηε-σ on April 14, 2008, 02:33:40 AM
ok I added this to a fresh install of 1.1.4 on my localhost using xampp

this is the only mod. first i tried version 1.5 and then i uninstalled that and installed version 1.4


How in the world do i get this mod to display images using slimbox? I tried everything and still can't get the stupid images do be displayed with in slimbox or lightbox.

You shouldn't have to do anything to get the images to display in the lightbox/slimbox. Image attachments that have a thumbnail, urls to images and images that use the IMG bbcode should all display in a lightbox/slimbox.

I know you said it was a fresh install but, was you using the default template? If so is there anyway I could access this install and see the page source? (You can post or PM me the url)

[кѕ]ваηε-σ

April 14, 2008, 02:13:05 PM #10 Last Edit: April 14, 2008, 02:17:44 PM by [кѕ]ваηε-σ
no it's running off of a a usb thumb stick on my localhost. I can post a "right click --> View source" of the page. is that what you want?

Click my sig, I dare you. (you might enjoy it)


I have 1337 M0DЄЯΑŦ0Я ѕκιŁŁѕ.


Quote from: ваηε-σ, #lëñņðN`, мµŋτς[02:42] [кѕ]ваηε-σ: I just pwned microsoft and completely ghosted one hard drive onto another. Two computers with the exact same operating system, exact same everything.
[02:42] ⌠Ķζ⌡мµŋτς ©  / DarkForce: lmfao, XD
[02:43] *[Ҝﮘ] #lëñņðN` ¨εﮘ`: hahahaha, noice

quake101

Quote from: [кѕ]ваηε-σ on April 14, 2008, 02:13:05 PM
no it's running off of a a usb thumb stick on my localhost. I can post a "right click --> View source" of the page. is that what you want?
That would work. Just PM me the page source.


teamvtec


exxocet

April 16, 2008, 06:14:14 AM #14 Last Edit: April 16, 2008, 06:16:41 AM by exxocet
In Opera browser it looks foggy, just like a white 20% transparency layer is overlayed over the image.

SgtMic

April 17, 2008, 01:59:43 AM #15 Last Edit: April 17, 2008, 10:39:25 AM by SgtMic
Had a huge problem with this mod and IE7. Users were not able to access the boards. They could navigate through the maintab links just fine. Just not the boards. The issue is created in the index.template.php. I was able to narrow it down to just that file. Once I uninstalled lightbox, IE7 works just fine.
I use Firefox and had no problems at all.

It actually occurred on 2 of my sites so I know it wasn't a fluke.

Any ideas on a fix?


ETA: Forums are running beta3 public.
There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)

FragaCampos

This mod is great, but when i have an image inside a url tag, the link doesn't work...  ::) :-[

quake101

Quote from: SgtMic on April 17, 2008, 01:59:43 AM
Had a huge problem with this mod and IE7. Users were not able to access the boards. They could navigate through the maintab links just fine. Just not the boards. The issue is created in the index.template.php. I was able to narrow it down to just that file. Once I uninstalled lightbox, IE7 works just fine.
I use Firefox and had no problems at all.

It actually occurred on 2 of my sites so I know it wasn't a fluke.

Any ideas on a fix?


ETA: Forums are running beta3 public.

I confirm this is a bug only using SMF 2.0 Beta 3 Public. I'm adding it to my SMF 2.0 Beta 3 Public "to-do" list. :)

quake101

Quote from: FragaCampos on April 17, 2008, 09:53:08 AM
This mod is great, but when i have an image inside a url tag, the link doesn't work...  ::) :-[
Booo...
Does this happen with v1.4 also? What version of SMF?

SgtMic

Quote from: quake101 on April 17, 2008, 12:02:39 PM
I confirm this is a bug only using SMF 2.0 Beta 3 Public. I'm adding it to my SMF 2.0 Beta 3 Public "to-do" list. :)

Good to go.
There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)

Advertisement: