Advertisement:

Author Topic: Bridge SMF 1.1 e107 beta 1  (Read 760719 times)

Orstio

  • Guest
Bridge SMF 1.1 e107 beta 1
« on: January 12, 2008, 08:56:15 PM »
The bridge for e107 is available on the downloads page:

http://www.simplemachines.org/download/?bridges

Unzip it, and upload the "smf" folder inside to your e107_plugins folder.  Go to your e107 admin panel, and install it as any other e107 plugin.

Once installed, configure the plugin by typing in the absolute path to SMF, and deciding whether or not you want your forum wrapped in the e107 template.

Please report any errors or problems you encounter.

New in the beta version:

- SMF will detect your login from the e107 cookie.  Users will be migrated and logged in to SMF appropriately, automatically.
- Various small bugs fixed.

A special thanks to Harvester for the testing of this bridge.  :)

Offline TEOC2

  • Jr. Member
  • **
  • Posts: 207
Re: Bridge SMF 1.1 e107 beta 1
« Reply #1 on: January 24, 2008, 07:46:47 AM »
[SOLVED]
Im having a problem with this, i have the latest e107 and smf installed manually on the same database, compression is OFF in both.

When going to the forum i get a blank page, my path is set as ../www/forum

Heres the forum url,
http://www.chantelweb.co.uk/forum/
And the e107 url,
http://www.chantelweb.co.uk/e107/


I solved this by changing the absolute path to,
/home/mycpanelusername/public_html/forum
« Last Edit: January 24, 2008, 08:04:59 AM by TEOC2 »

Aeternus

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #2 on: January 28, 2008, 10:55:00 PM »
I have a problem with this bridge as well. It installed just fine, and it synchronizes with e107 like a charm, but I can't get the "Wrapped" option to work, all I get is a blank page when it's wrapped. The unwrapped version works just fine.

I'm running e107 0.7.11 and SMF 1.1.4

Aeternus

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #3 on: January 28, 2008, 11:51:58 PM »
Well nevermind my question, I've decided to switch to SMF with TinyPortal altogether :) You still might want to look into it, in case other people have the same issue :)

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #4 on: January 29, 2008, 06:51:15 AM »
When using a bridge, compressed output needs to be turned off in SMF.

Offline erlend_sh

  • Jr. Member
  • **
  • Posts: 307
  • Gender: Male
  • Lack of sleep is my drug
    • jMonkeyEngine
Re: Bridge SMF 1.1 e107 beta 1
« Reply #5 on: January 30, 2008, 06:00:03 AM »
I posted a support request about this on the CM's forum, but I guess this place should be better suited.

Earlier I was having problems with the .zip file for the bridge being corrupted. I am no longer experiencing this problem and I can unpack the .zip file without problems. However, when I try to upload the .zip-file directly into the e107 plugins folder, I am met with this error message:
Quote
The file did not upload. Filename: 'smf_1-1_e107_bridge_1-1_beta_1.zip' Error: The filetype application/x-zip-compressed is not allowed and has been deleted. (1) Admin MessageAn error has occurred, unable to un-archive the file PCLZIP extract error: 'PCLZIP_ERR_MISSING_FILE (-4)'
Am I the one doing something wrong, or is the file not working properly? (I'm doing this on a local host, planning to integrate it with SMF 1.1.4, although that is rather irrelevant seeing as I haven't really reached the point yet where SMF becomes a part of the issue). Is there any other way of adding this plugin? (I tried just pasting in the folder, but it didn't seem to be able to read it then.)

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #6 on: January 30, 2008, 06:42:52 AM »
Quote
Unzip it, and upload the "smf" folder inside to your e107_plugins folder.

That would indicate you should unzip the file first, then upload its contents.

Offline quadraxas

  • Semi-Newbie
  • *
  • Posts: 43
  • Gender: Male
Re: Bridge SMF 1.1 e107 beta 1
« Reply #7 on: February 01, 2008, 06:37:40 PM »
hi,
Orstio

i have that white page problem,

i installed smf and e107 on same database and installed the plugin using e107's plugin uploader.

running on localhost,

e107 url: http://localhost/
e107 path: C:\wamp\www

forum url: http://localhost/forum
forum path:C:\wamp\www\forum

i entered this as absolute path : C:\\wamp\\www\\forum

turned of the compressed output on smf, and im still getting a white page both in wrapped and unwrapped mode.
« Last Edit: February 01, 2008, 06:40:09 PM by quadraxas »

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #8 on: February 01, 2008, 08:00:22 PM »
Are you able to turn on error reporting?

Offline quadraxas

  • Semi-Newbie
  • *
  • Posts: 43
  • Gender: Male
Re: Bridge SMF 1.1 e107 beta 1
« Reply #9 on: February 01, 2008, 08:19:43 PM »
i set the error_reporting to  E_ALL in php.ini, what should i do now?


EDIT:
also checked the error logs and got these two:

[01-Feb-2008 20:34:05] PHP Warning:  mysql_fetch_array(): supplied argument is not a valid MySQL result resource in C:\wamp\www\administrator\components\com_smf\admin.smf.php on line 154

[01-Feb-2008 20:34:25] PHP Warning:  Invalid argument supplied for foreach() in C:\wamp\www\administrator\components\com_smf\admin.smf.php on line 493


i tried but couldnt get same errors(or couldnt get them logged)
« Last Edit: February 01, 2008, 08:21:18 PM by quadraxas »

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #10 on: February 01, 2008, 08:59:11 PM »
Quote
[01-Feb-2008 20:34:05] PHP Warning:  mysql_fetch_array(): supplied argument is not a valid MySQL result resource in C:\wamp\www\administrator\components\com_smf\admin.smf.php on line 154

[01-Feb-2008 20:34:25] PHP Warning:  Invalid argument supplied for foreach() in C:\wamp\www\administrator\components\com_smf\admin.smf.php on line 493

Those are Mambo errors, not e107 errors....

Offline quadraxas

  • Semi-Newbie
  • *
  • Posts: 43
  • Gender: Male
Re: Bridge SMF 1.1 e107 beta 1
« Reply #11 on: February 01, 2008, 09:05:20 PM »
right, yes. tried mambı before e107 sorry.

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #12 on: February 02, 2008, 06:37:35 AM »
Well, without seeing it for myself, and without descriptive error messages, it's impossible t otell what is causing your blank screen.  Blank screen can be an indication of almost anything.

Offline quadraxas

  • Semi-Newbie
  • *
  • Posts: 43
  • Gender: Male
Re: Bridge SMF 1.1 e107 beta 1
« Reply #13 on: February 02, 2008, 05:35:11 PM »
thank you for your effort Orstio, i already gave up.

SSI FTW!!! :D

Offline rigable

  • Newbie
  • *
  • Posts: 6
Re: Bridge SMF 1.1 e107 beta 1
« Reply #14 on: February 04, 2008, 09:40:27 AM »
I have a bit of a different problem with this bridge.  I was able to unzip and install the bridge with no problems.  when i click on "forum", it takes me to my smf forum... it looks great... everything there functions great, but when i hit "home" from the forum, i just get a white page with a bunch of code on it.

Quote
h="20" align="center">
                  <a href="hxxp:www.billionairebusinessschool.net/membersarea/e107_plugins/smf/smf.php?action=login [nonactive]"><img src="hxxp:billionairebusinessschool.net/forum/Themes/default/images/icons/login.gif [nonactive]" alt="Login" /></a>
               </td>
               <td class="windowbg2" valign="middle">
                  <form action="hxxp:www.billionairebusinessschool.net/membersarea/e107_plugins/smf/smf.php?action=login2 [nonactive]" method="post" accept-charset="ISO-8859-1" style="margin: 0;">
                     <table border="0" cellpadding="2" cellspacing="0" align="center" width="100%"><tr>
                        <td valign="middle" align="left">
                           <label for="user"><b>Username:</b><br />
                           <input type="text" name="user" id="user" size="15" /></label>
                        </td>
                        <td valign="middle" align="left">
                           <label for="passwrd"><b>Password:</b><br />
                           <input type="password" name="passwrd" id="passwrd" size="15" /></label>
                        </td>
                        <td valign="middle" align="left">
                           <label for="cookielength"><b>Minutes to stay logged in:</b><br />
                           <input type="text" name="cookielength" id="cookielength" size="4" maxlength="4" value="60" /></label>
                        </td>
                        <td valign="middle" align="left">
                           <label for="cookieneverexp"><b>Always stay logged in:</b><br />
                           <input type="checkbox" name="cookieneverexp" id="cookieneverexp" checked="checked" class="check" /></label>
                        </td>
                        <td valign="middle" align="left">
                           <input type="submit" value="Login" />
                        </td>
                     </tr></table>
                  </form>
               </td>
            </tr>
         </table>
      </div>
   </div>
   </div>

   <div id="footerarea" style="text-align: center; padding-bottom: 1ex;">
      <script language="JavaScript" type="text/javascript"><!-- // --><![CDATA[
         function smfFooterHighlight(element, value)
         {
            element.src = smf_images_url + "/" + (value ? "h_" : "") + element.id + ".gif";
         }
      // ]]></script>
      <table cellspacing="0" cellpadding="3" border="0" align="center" width="100%">
         <tr>
            <td width="28%" valign="middle" align="right">
               <a href="hxxp:www.mysql.com/ [nonactive]" target="_blank"><img id="powered-mysql" src="hxxp:billionairebusinessschool.net/forum/Themes/default/images/powered-mysql.gif [nonactive]" alt="Powered by MySQL" width="54" height="20" style="margin: 5px 16px;" onmouseover="smfFooterHighlight(this, true);" onmouseout="smfFooterHighlight(this, false);" /></a>
               <a href="hxxp:www.php.net/ [nonactive]" target="_blank"><img id="powered-php" src="hxxp:billionairebusinessschool.net/forum/Themes/default/images/powered-php.gif [nonactive]" alt="Powered by PHP" width="54" height="20" style="margin: 5px 16px;" onmouseover="smfFooterHighlight(this, true);" onmouseout="smfFooterHighlight(this, false);" /></a>
            </td>
            <td valign="middle" align="center" style="white-space: nowrap;">
               
      <span class="smalltext" style="display: inline; visibility: visible; font-family: Verdana, Arial, sans-serif;"><a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by SMF 1.1.4</a> |
<a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2006-2007, Simple Machines LLC</a>
      </span>
            </td>
            <td width="28%" valign="middle" align="left">
               <a href="hxxp:validator.w3.org/check/referer [nonactive]" target="_blank"><img id="valid-xhtml10" src="hxxp:billionairebusinessschool.net/forum/Themes/default/images/valid-xhtml10.gif [nonactive]" alt="Valid XHTML 1.0!" width="54" height="20" style="margin: 5px 16px;" onmouseover="smfFooterHighlight(this, true);" onmouseout="smfFooterHighlight(this, false);" /></a>
               <a href="hxxp:jigsaw.w3.org/css-validator/check/referer [nonactive]" target="_blank"><img id="valid-css" src="hxxp:billionairebusinessschool.net/forum/Themes/default/images/valid-css.gif [nonactive]" alt="Valid CSS!" width="54" height="20" style="margin: 5px 16px;" onmouseover="smfFooterHighlight(this, true);" onmouseout="smfFooterHighlight(this, false);" /></a>
            </td>
         </tr>
      </table>
      <script language="JavaScript" type="text/javascript"><!-- // --><![CDATA[
         window.addEventListener("load", smf_codeFix, false);
         function smf_codeFix()
         {
            var codeFix = document.getElementsByTagName ? document.getElementsByTagName("div") : document.all.tags("div");

            for (var i = 0; i < codeFix.length; i++)
            {
               if (codeFix.className == "code" && (codeFix.scrollWidth > codeFix.clientWidth || codeFix.clientWidth == 0))
                  codeFix.style.overflow = "scroll";
            }
         }
      // ]]></script>
   </div>
   <div id="ajax_in_progress" style="display: none;">Loading...</div>
</body></html></div></div>
</div>
</div>
</div>
<div class='dbottom'>
<div class='left'></div>
<div class='right'></div>
<div class='center'></div>
</div>
      </div>   </div>   <div id='footer'>      This site is powered by <a href="hxxp:e107.org/ [nonactive]" rel="external">e107</a>, which is released under the terms of the <a href="hxxp:www.gnu.org/ [nonactive]" rel="external">GNU</a> GPL License.<br />      <br />   </div></div></body></html>HTTP/1.1 302
Date: Mon, 04 Feb 2008 14:36:48 GMT
Server: Apache/1.3.39 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a PHP-CGI/0.1b
X-Powered-By: PHP/5.2.4
Location: news.php
Keep-Alive: timeout=15, max=96
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html

0

Once this happens, i can hit "refresh" on my browser and poof everything comes back up like it should to the home page.  The URL for my site is hxxp:www.billionairebusinessschool.net/membersarea/ [nonactive].  Any ideas on this one?  Thanks!

Rich

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #15 on: February 04, 2008, 10:19:58 AM »
Try bumping up your PHP RAM to 32MB in your php.ini.

Offline rigable

  • Newbie
  • *
  • Posts: 6
Re: Bridge SMF 1.1 e107 beta 1
« Reply #16 on: February 04, 2008, 10:40:55 AM »
This may be a dumb question, but where would i find that?

Offline schleppo

  • Newbie
  • *
  • Posts: 3
Re: Bridge SMF 1.1 e107 beta 1
« Reply #17 on: February 11, 2008, 03:44:10 PM »
When I create a new "user class" in e107 and assign a member, the "membergroup" gets created automatically in SMF but there are no members assigned.  I then have to manually assign the member again in SMF.  Any idea what would cause this?  I am using SMF 1.1.4 and e107 0.7.10.  Thanks.

Orstio

  • Guest
Re: Bridge SMF 1.1 e107 beta 1
« Reply #18 on: February 11, 2008, 04:30:49 PM »
That's odd -- there is nothing in the bridge that would automatically create a new membergroup in SMF based on a user class being created in e107....

Offline schleppo

  • Newbie
  • *
  • Posts: 3
Re: Bridge SMF 1.1 e107 beta 1
« Reply #19 on: February 11, 2008, 04:38:11 PM »
Hmm, so there's not a mechanism in the bridge to allow SMF forum permissions/groups to be managed by e107?