• Welcome to Simple Machines Community Forum. Please login or sign up.

Text size and captcha problem

Started by dxyy, December 12, 2007, 08:27:28 PM

Previous topic - Next topic

dxyy

SMF Version: SMF 1.1.4
Mods installed: SMF 1.0.12 / 1.1.4 / 2.0 b1.1 Update
PaypalDonations
MessagePreviewOnHover
Users Active in Last 24 Hours
vReportBoard Mod
Post Count Warning
Referrals Mod
Country Flags
No Spam by Guests!
Skype Name Mod
Reg Bar
Global Headers Footers
Ad Managment
SMFShop
Language Drop
PM On Registration
Enhanced Quick Reply Box 2.0
Signature Settings Mod
SMF Gallery Lite
YouTube BBC Tag (XHTML Compliant)
Using default theme: yes
Link to site: http://www.daxueyingyu.com/forum/index.php?referredby=1
Error log: None?

Ok, I searched the community and found something about problems with visual verification (captchas), but I still wasn't able to solve my problem.

I have two problems.

The first problem is that the captchas are not displayed if a member uses simplified Chinese (utf-8). If a members uses English, there is no problem. I'm not sure how long this problem has existed, because previously it wasn't possible to use Chinese on the registration page. I tried many different things, and in my experiments I noticed that if I saved the index.chinese-simplified-utf8.php file as ANSI rather than utf-8 that the captchas work! However, this is not a viable solution as it would mean that I need to replace every character in that file with something like "你看起..."


The second problem is that for some reason if I try to make some changes to my simplified Chinese (utf-8) language files the text size in IE is too large. Everything looks fine in Firefox, but when a members uses Chinese and IE the font is too large. For example I tried to add some text strings(?) to modifications.chinese-simplified-utf8.php, but when I uploaded it, the text displayed with Chinese and Internet Explorer is too large.

If you need some more details I can write more, but for now I don't want to write too much as I have a tendency to write long winded posts that seem to turn users off from reading them. :P

Thanks to anyone who can help me. :)


KGIII

I see you have a 2.0 something or other installed - is this SMF 2.0 beta? The site says no but that's easy to fake. If the answer is yes then you're best off using the beta section or the charter member's section.

My PC Support Forum
Please ask in-thread before PMing
                   SMF Help
                   Visit My Blog

How can we improve the support process?:
http://www.simplemachines.org/community/index.php?topic=163533.0

SMF vs. Godzilla? Who do you think will win?

dxyy

I don't have SMF 2.0 beta. I just copied a list of my mods, and I guess the first one is from when I updated from 1.1.3 to 1.1.4. ;)

target_locked

Your first problem:
How can a guest change your forum language?
If he is already a member, there is no need to go to registration page ! The default theme/language is set by administrator?


I don't know if my case will help you:

When I edit the file "index.template.php" in every theme (just add a line next to the SMF copyright at bottom at the main index), I wanted to use my own language UTF-8 2 byte.
What I do is:
Use editor "NotePadPlus" and change format to "Encode in UTF-8" so that I can type in and see my UTF-8 language.
Then save it.
Run the forum, everything work as normal except the CAPCHA, it does not display in both Admin/Member registration/Setting review and in new registration page. In this case no one can register new account because they can not see the CAPCHA image.

And here is the solution:
Do as above but before saving the PHP file, switch the format to "Encode in ANSI", then save. Pls note, when switch to ANSI, you will not see your language, it became alien font. But just close it and open again, you can see you language although the default view is ANSI.
By this way, I don't have to replace every character in that file with something like "你看起..."

Hope that help.
SMF 1.1.4 now 1.1.8
¡uʍop ǝpısdn ɹoʇıuoɯ ʎɯ pǝuɹnʇ oɥʍ ¡ʎǝɥ

dxyy

Quote from: target_locked on December 13, 2007, 08:50:52 PM
Your first problem:
How can a guest change your forum language?
If he is already a member, there is no need to go to registration page ! The default theme/language is set by administrator?
I have a language drop down mod installed, so guests do not need to register in order to change the language. ;)

It's the same as this forum, you don't need to be logged in to change the language, you can just select it where it says "Select language"

Anyway, I'll try what you suggested and hopefully it works. :)

Sarge


    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

dxyy

Quote from: Sarge on December 16, 2007, 02:51:38 AM
Let us know how it goes. :)
Well, I uninstalled the language drop-down since it appeared to not be XHTML compliant.

Anyway, I don't think my previous update to 1.1.4 was successful, so I also redid that and this time I am sure that everything is fine.

I will reinstall the language drop down and report back here later. :P

metallica48423

I see the text fine using the chinese-simplified

As for the font size problem -- it could be a problem with the encoding of the language file, but if its happening in one browser vs. another it sounds like a browser thing
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

dxyy

Sorry for the confusion.

Everything is working on my forum right now since I reverted to the older files I had saved on my computer etc.

Anyway, I posted something in another thread about this, here is a quote of my last post:
Quote from: hugodiaz on December 17, 2007, 03:57:54 PM
It seems that as long as I save my Modifications.chinese-simplified-utf8 as utf-8 that the captcahs do not work if someone uses Chinese. When I am using English everything is fine.

Is this a bug? ???

EDIT: Also, if I modify the index.chinese-simplified-utf8 file (even though it was already saved as utf-8) the captcha stops working! Gosh, is this problem only something I am experiencing? :(

metallica48423

Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     


metallica48423

i don't think notepad respects encodings. 

I'd find a text editor program.  A search here will turn up a few as well :)
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

dxyy

Ok, well I also have PSPad, so I'll try that and report back here. ;)

dxyy

Ok, so things seem to be fine now.

Once again thanks for the assistance! :)

Advertisement: