• Welcome to Simple Machines Community Forum. Please login or sign up.

The upgrader found some old or outdated language files.

Started by chriswe, January 14, 2007, 05:45:50 AM

Previous topic - Next topic

chriswe

Hi,

Everytime when I try to upgrade, I got this message:
The upgrader found some old or outdated language files.
What can I do to upgrade correctly?
Thanks!

Christiaan

Dannii

Are you using any other languages than English? If so, make sure you've uploaded the new language packs too. And check that all the files were uploaded correctly, sometimes the files might not have completely uploaded.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Rhuggs

Quote from: eldʌkaː on January 14, 2007, 06:43:45 AM
Are you using any other languages than English? If so, make sure you've uploaded the new language packs too. And check that all the files were uploaded correctly, sometimes the files might not have completely uploaded.

I'm not using anything but English, have no mods at all, was on a clean 1.1.1 prior to upgrading, and the only thing custom is that I'm running the Juno theme.  I loaded the upgrade with no problems, hit no errors at all, and when I go back to check files I show the language file is not updated.

Now if I've got no mods, and am running clean 1.1.1, and you guys produce an upgrade to 1.1.2, why wouldn't you update all the language files???  Makes no sense at all to me!  I do have French users, and these language files are the stock one's that came with the clean load of 1.1.1.  My brain can't handle the thought that if you produce an upgrade to the stock package, that I've got to go upgrade something that didn't upgrade cause it wasn't in the upgraded upgrade that upgraded the upgrade???  Are you guys run by Microsoft????
...if I only had a brain...

Dannii

Because there are almost 30 languages. You had to download a language pack to start with, so you can download a language pack to update.
"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Rhuggs

Forgive me if I'm stubborn, hard headed, and yet practical, but I didn't EVER download any language files or apps. I installed a fresh, clean SMF.  Then you guys come up with an upgrade within a couple of weeks.  Great. No prob.  So why doesn't your upgrade work on a fresh, clean install?  If the language files came with SMF, why on earth wouldn't you update them?

I know, I'm talking to a post - I'll get the normal "well just follow my directions and shut up" response, but it makes ABSOLUTELY NO SENSE why a clean version would need something added to it for a clean update???!!!???  Or has common sense just left this plane?
...if I only had a brain...

SleePy

You said you already upgraded to 1.1.1? You do not need to run the upgrade.php for a upgrade from 1.1.1 to 1.1.2
The 1.1 line is done with its database changes and you do not need to run this file again unless you are upgrading a forum that is not 1.1 Final. or in the future when the next line is released
The upgrade is looking for all language files to be 1.1.2 since there was some language file changes to fix captcha.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

青山 素子

Quote from: Rhuggs on February 28, 2007, 11:58:43 PM
Forgive me if I'm stubborn, hard headed, and yet practical, but I didn't EVER download any language files or apps. I installed a fresh, clean SMF.  Then you guys come up with an upgrade within a couple of weeks.  Great. No prob.  So why doesn't your upgrade work on a fresh, clean install?  If the language files came with SMF, why on earth wouldn't you update them?

Only the English files come with SMF. All other languages are additional packs (because of the size of including all languages).

Quote from: Rhuggs on February 19, 2007, 06:05:09 PM
Now if I've got no mods, and am running clean 1.1.1, and you guys produce an upgrade to 1.1.2, why wouldn't you update all the language files???  Makes no sense at all to me!  I do have French users, and these language files are the stock one's that came with the clean load of 1.1.1.

French isn't included in the base SMF package. If you used webinstall or an installer provided through Fantastico or similar, it is likely that the extra language files were added to the install. They are not, however, part of the base SMF and are not included in the update for that reason.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


Rhuggs

That would explain it then, and I take back my highly negative comments.  It was loaded via Fantastico and I've verified that they do load a slew of language files.  Now if someone could direct me to the files so I can update them I'd be much more gracious and appreciative...lol

Thanks for your kind, and well formed responses!!!
...if I only had a brain...

Dannii

"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

Rhuggs

...if I only had a brain...

Advertisement: