• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 04:49:55 PM

News:

Wondering if this will always be free?  See why free is better.


SMF Gallery

Started by SMFHacks.com Team, September 16, 2006, 07:13:02 PM

Previous topic - Next topic

metzbgsu

Do you think you could add a link tree at the top of the gallery like the forums and calendar have?  Or will that only be in the pro version?

vbgamer45

Might it just adds more processing to the forum which i try to avoid.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

shacon

Is there any future plans for a ver 2.X 3 Beta update.?

Thank You

-shacon :)
we make a living by what we get...we make a life by what we give

vbgamer45

Once SMF 2.0 final is released or an RC release I will update it. Right now too many changes happening for me to update it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

shacon

^  Great !! 

Looking forward to it once again.

-shacon  :)
we make a living by what we get...we make a life by what we give

astrodaddy

March 29, 2008, 05:13:55 PM #1285 Last Edit: March 29, 2008, 05:16:05 PM by astrodaddy
Hello,

I have the gallery lite mod installed and everything seems be ok except the images do not show up at all (thumbnails or otherwise). The gallery is chmodded to 755 and its not showing any errors in the forum error log at all.

Here are my details,

Version Information:
Forum version: SMF 1.1.4
Current SMF version: SMF 1.1.4
PHP version: 4.4.7
MySQL version: 4.1.22-standard
Server version: Apache/1.3.39 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a PHP-CGI/0.1b
GD version: bundled (2.0.28 compatible)

On a test image I uploaded using the gallery mod, heres the link it has to the full sized image (forum address edited because its a private forum and I dont wish to advertise it).

http://www.xxxxxxxxxx.com/public_html/members_forum/gallery/thumb_1_28_03_08_1_14_26.gif

Any ideas?


vbgamer45

What is your gallery url set at make sure it ends a /
And check if you are able to access the files in a browser.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

astrodaddy

Thanks for the quick reply!

The / is at the end of the gallery URL, but it gives this error when I try to view a pic in the browser,


Forbidden
You don't have permission to access /public_html/members_forum/gallery/thumb_1_29_03_08_4_19_16.jpg on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


vbgamer45

Is that the right path and do files exist in the gallery folder?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

astrodaddy

I believe its the right path, and the files do exist in the gallery folder.

I can double check with cpanel if you need me too.

astrodaddy

Quick update, after checking cpanel I discovered the jpg files are chmodded to 644, is there a way to make the gallery make the files 755 by default?

Hers a copy/paste of the screen in the File Manager of cpanel.

/ public_html / members_forum / gallery / (Current Folder)   
Create New Folder   
Upload file(s)   
Up one level   
Create New File   
1_29_03_08_4_19_16.jpg 32 k 0644
placeholder.txt 0 k 0775
thumb_1_29_03_08_4_19_16.jpg 18 k 0644

astrodaddy

I manually changed the permission to 755 in cpanel and tried to view it again in my browser, but IE still gives the forbidden error.

vbgamer45

Might be a mod_security issue search on the forums and they have fix for that.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

astrodaddy

Will go check, thanks!

astrodaddy

Update - Its working now!

I have the Download mod installed, and since it works I figured the paths must be correct. So I simply copied the URL from the download mod and pasted it into the gallery lite mod URL, changed /downloads/ to /gallery/ and it started working!

Im now going to go check out your Pro edition!

Thanks again!


Marsh

any plans on updating this to beta 3 anytime soon?
625,195 Posts in 50,808 Topics by 34,295 Members.

Powered by SMF 2.0

www.touchofdeathproductions.com

nwobhm

Hi,
I have translated SMF gallery lite 1.8.2 ver. to finnish and I have instelled it also. But I just can't get the Gallery tab appear into the menubar.
I have SMF 1.1.4 version with Dilbermc theme with finnish language.

I can see gallery settings and configurations in finnish in the administrator area and I see the permissions also. When I set persmissions to different groups, they cannot see the gallery tab in the men bar, but neither can I. But direct link does work.

perplexed

Quote from: marsh on March 30, 2008, 03:10:52 AM
any plans on updating this to beta 3 anytime soon?

look further up this page for the answer :)


Quote from: vbgamer45 on March 27, 2008, 10:58:05 PM
Once SMF 2.0 final is released or an RC release I will update it. Right now too many changes happening for me to update it.

slackerpunk

March 30, 2008, 09:31:54 AM #1298 Last Edit: March 30, 2008, 09:35:54 AM by slackerpunk
Hi,

I only got one issue when trying to install

2.     Execute Modification     ./Themes/default/languages/Modifications.english-utf8.php     Test failed

but the mod was installed.

Now when I try to save the settings I get this error message

Can't find record in 'smf_settings'
File: /var/www/vhosts/pinoypsp.com/httpdocs/Sources/Subs.php
Line: 706

vbgamer45

I would uninstall and reinstall haven't seen that exact error before but I might be related with the database install for the mod.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Advertisement: