Advertisement:

Author Topic: Spell checkers don't work - or very badly - (Solved)  (Read 1273 times)

Offline meylodie

  • Semi-Newbie
  • *
  • Posts: 59
Spell checkers don't work - or very badly - (Solved)
« on: January 23, 2013, 09:15:23 AM »
Hi,
The forum where it happens is LinuxVillage (beta) : http://beta.linuxvillage.net

The environment:
I am using Archlinux, with Firefox 18.0.1 and the latest French and US spelling dictionnaries from this page:
https://addons.mozilla.org/en-US/firefox/language-tools

The issue:
In LinuxVillage I can't get the spelling dictionaries to do their job. Once they appear, once they don't, I tried removing them, adding them again : no way.

Here, in the present forum, it does work.

in a phpbb forum where I don't meet the issue, it shows this way:


in LinuxVillage:


and here it shows fine as it does here, in the present forum.

How can I fix it ?

Thanks,
mélodie









« Last Edit: January 26, 2013, 07:46:58 PM by meylodie »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,982
    • StoryBB/StoryBB on GitHub
Re: Spell checkers don't work (or very badly)
« Reply #1 on: January 23, 2013, 09:16:41 AM »
Spell check in the browser doesn't work when in WYSIWYG mode, which you're in on your forum, but not here unless you enabled it.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline meylodie

  • Semi-Newbie
  • *
  • Posts: 59
Re: Spell checkers don't work (or very badly)
« Reply #2 on: January 26, 2013, 07:39:29 PM »
Arantor,

Thank you very much. I would never have found it by myself, so I switch right on and will retry again. I also noticed that the copy/paste feature wasn't available either sometimes. I'll check that one too.

PS: this problem is solved but surprise ! Now without WYSIWIG the background of the editor field is black in the CC 2 theme, which is the default and the one used by most actual members... I'll have to edit the CSS... :/