xx Various issues with 1.1.21 and advice needed!

September 10, 2019, 07:55:45 PM by Leon P
Hi there!

We have a forum for our business which is running on 1.1.21 and has developed a series of problems over the past couple of years.  I'm not very tech-minded myself so we have a webguy who looks after it for us, but he's been increasingly busy with his day job recently and hasn't been able to complete any upgrades or maintenance for us, for quite some time now.  I'm really looking for any advice that you can give as to why some of these things are happening and what the potential fix is for them?  If it's something I can do through my Moderator login, I might be able to take of it myself?

Apostrophes - If anyone tries to start a topic with an apostrophe in the Subject box, when you click 'Post' it comes up with a 'Hacking attempt' screen and won't post the topic. 

Board Order - The order of our boards and sub-boards has jumped all over the place recently.  They are all showing in the correct order in the Admin section, but from the front end they're all out of order.

Newsletters - We have a little over 2000 members and we used to send monthly newsletters out to them.  We had to stop doing this as the newsletter sending process was taking 20+ minutes with several 'MySQL has gone away' messages.  I would normally F5 refresh when this screen came up and it would eventually work it's way through to 100% sent.  Many members would receive the newsletter 2 or 3 times though.

Newsletters (again!) - The above error evolved into simply crashing the forum completely and we would have to contact the webguy to bring it back up.  I'm afraid I don't know what he had to do to fix it, I think he mentioned that it could be the volume of emails causing the hosts to take it down?  Or dead emails from old accounts that were bouncing back and causing an error?

Registration - We turned off the registration about a year ago as we were getting so many spam accounts trying to get in.  Ideally I'd like it turned back on with some kind of bot-check or Captcha check box, but I don't think I can do this through my own account?


I'm guessing that an upgrade would probably help to fix most of these but I don't think there's any way for me to do that from my end?  The forum is hosted through the webguy's account as well, so I can't access any of the files for it.

I am able to change emails and passwords through my Moderator account, so there's a chance I could edit the Admin account details to give myself access to that?  Would that have any effect?

Apologies for not having more info on this, as I say I'm not a tech guy but I really need to get something sorted out to fix our forum.  It's a vital part of our business and these problems (especially the newsletter being out of action) are really affecting our sales.

Thanks for any help or advice you can give, our forum is here: pendrakenforum.co.uk
5 comments | Write Comment

solved upgrade from 1.1.21 to 2.0.15 Mysql error

September 09, 2019, 06:38:39 AM by maudio
Hello, i'm trying to upgrade my forum from 1.1.21 to 2.0.15

during the upgrade process (with upgrade.php) i've got the folling error:

Executing upgrade script 2 of 2.
Executing: "Adding permission profiles for boards." (16 of 42 - of this script)

!!Error!
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE id_board IN (15)' at line 3



i'm using  MYSQL v.5.6 on my host.

thanks in advance
2 comments | Write Comment

solved Because of MySQL 5.6 to 5.7 Upgrade ?

September 07, 2019, 04:29:03 PM by halimzhz
Dear All,

I'm a web hosting company and today one of my client reported about he's SMF forum giving an error:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

For your information i upgrade my MySQL from 5.6 to 5.7 few weeks ago and i dont do a test for this client forum, but i know when the server using MySQL 5.6, this client doesnt have any problem, what i found from Settings.php, the SMF version is 1.1

So is it possible to say the problem is because of MySQL 5.7 is not compatible with SMF 1.1 ? I did test with database connection and its not an issue with database username and password.

I hope somebody can advice on how to solve this problem. Thank you so much

10 comments | Write Comment

moved MOVED: Search Restrictions

August 23, 2019, 10:46:35 AM by Irisado
This topic has been moved to SMF 2.0.x Support.

https://www.simplemachines.org/community/index.php?topic=569314.0
0 comments

moved MOVED: could u help me disbale this function? Warning - while you were typing a new re

August 22, 2019, 05:27:17 AM by Irisado
This topic has been moved to SMF 2.0.x Support.

https://www.simplemachines.org/community/index.php?topic=569296.0
0 comments

moved MOVED: help me. how to stay at current topic after reply?

August 21, 2019, 03:31:31 PM by Irisado
This topic has been moved to SMF 2.0.x Support.

https://www.simplemachines.org/community/index.php?topic=569287.0
0 comments

moved MOVED: Forum attachments lost since migration

August 18, 2019, 06:19:57 AM by Aleksi "Lex" Kilpinen
This topic has been moved to Chit Chat.

https://www.simplemachines.org/community/index.php?topic=561144.0
0 comments